?>
Задания:I.В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и«/» — операции сложения, вычитания, умножения и деления. Правила и порядоквыполнения операций соответствуют правилам арифметики. Определите значениепеременной b после выполнения алгоритма:1 Заданиеа := 2b := 4а := 2*а + 3*bb := a/2*b В ответе укажите одно целое число — значение переменной b. (ответ: b= 2 ЗаданиеОпределите значение переменной b после выполнения алгоритма:а := 5b := 4а := 2*а + 3*bb := a/2*b В ответе укажите одно целое число — значение переменной b.2. Задание Определите значение переменной b после выполнения алгоритма:а := 4b := 4а := 2*а + 3*bb := a/2*b В ответе укажите одно целое число — значение переменной b.3. Задание Определите значение переменной b после выполнения алгоритма:а := 6b := 4а := 2*а + 3*bb := a/2*b В ответе укажите одно целое число — значение переменной b.4. ЗаданиеОпределите значение переменной b после выполнения алгоритма:а := 7b := 4а := 2*а + 3*bb := a/2*b В ответе укажите одно целое число — значение переменной b.ОТДЕЛЬНО Какие существуют виды данных?
Ответы
{
int[,] arr = new int[3, 3];
Random c = new Random(DateTime.Now.Millisecond);
for (int i = 0; i < 3; i++)
for (int j = 0; j < 3; j++)
arr[i, j] = c.Next(1, 9); //заполнение матрицы
//тебе это не надо, т.к. она дана
//заданный интервал
int a = 3;
int b = 3;
int sum = 0;
int proizvedenie = 1;
for (int i = 0; i < a; i++)
{
for (int j = 0; j < b; j++)
{
sum += arr[i, j];
proizvedenie *= arr[i, j];
}
}
Console.WriteLine("Матрица:");
Console.WriteLine("{0} {1} {2}", arr[0, 0], arr[0, 1], arr[0, 2]); Console.WriteLine("{0} {1} {2}", arr[1, 0], arr[1, 1], arr[1, 2]); Console.WriteLine("{0} {1} {2}", arr[2, 0], arr[2, 1], arr[2, 2]); Console.WriteLine("Сумма = {0}", sum); Console.WriteLine("Произведение = {0}", proizvedenie); Console.ReadLine();
}
}