petr2077
?>

Исполнитель К17 преобразует число, записанное на экране. У исполнителя есть три команды, которым присвоены номера: 1. Прибавить 1 2. Прибавить 3 3. Умножить на 2 Программа для исполнителя К17 - это последовательность команд. Сколько существует таких программ, которые исходное число 1 преобразуют в число 13 и при этом траектория вычислений программы содержит число 4 и число 9?

Информатика

Ответы

Maria095096
В C++
#include <iostream>
#include <iomanip>
#include <ctime>
int main()
{
    using namespace std;

    const int N = 5;
    const int M = 6;

    int A[N][M];

    //Как-нибудь заполняем массив
    srand(time(0));
    for (int i = 0; i < N; ++i)
        for (int j = 0; j < M; ++j)
            A[i][j] = rand() % (N * M) + 1;
    for (int i = 0; i < N; ++i)
    {
        for (int j = 0; j < M; ++j)
            cout << setw(4) << A[i][j];
        cout << endl;
    }

   
    //Подсчитываем сумму всех элементов массива
    int sum = 0;

    for (int i = 0; i < N; ++i)
        for (int j = 0; j < M; ++j)
            sum += A[i][j];

    //Вычитаем из полученной суммы повторяющиеся элементы
    for (int i = 0; i < N; ++i)
        for (int j = 0; j < M; ++j)
        {
            bool flag = false;
            for (int i1 = 0; i1 < N; ++i1)
            {
                for (int j1 = 0; j1 < M; ++j1)
                    if (!(i == i1 && j == j1))
                        if (A[i][j] == A[i1][j1])
                        {
                            sum -= A[i][j];
                            flag = true;
                            break;
                        }
                if (flag)
                    break;
            }
        }

    cout << "Sum of different: " << sum << endl;

    return 0;
}
marver201040
В C++
#include <iostream>
#include <iomanip>
#include <ctime>
int main()
{
    using namespace std;

    const int N = 5;
    const int M = 5;

    //Создаём массив и как-нибудь заполняем
    int A[N][M];
    srand(time(0));
    for (int i = 0; i < N; ++i)
        for (int j = 0; j < M; ++j)
            A[i][j] = rand() % (N * M) + 1;
   
    //Выводим его на экран
    for (int i = 0; i < N; ++i)
    {
        for (int j = 0; j < M; ++j)
            cout << setw(4) << A[i][j];
        cout << endl;
    }

    //Меняем местами 2ю и 3ю строки
    int temp = 0;
    for (int j = 0; j < M; ++j)
    {
        temp = A[1][j];
        A[1][j] = A[2][j];
        A[2][j] = temp;
    }

    //Выводим полученный массив на экран
    cout << "\n\n";
    for (int i = 0; i < N; ++i)
    {
        for (int j = 0; j < M; ++j)
            cout << setw(4) << A[i][j];
        cout << endl;
    }

    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Исполнитель К17 преобразует число, записанное на экране. У исполнителя есть три команды, которым присвоены номера: 1. Прибавить 1 2. Прибавить 3 3. Умножить на 2 Программа для исполнителя К17 - это последовательность команд. Сколько существует таких программ, которые исходное число 1 преобразуют в число 13 и при этом траектория вычислений программы содержит число 4 и число 9?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Kozlovao4
mrilyushchenko6
Андрееевич787
saljagindima
ekkim310
Dmitrii_Shamilevich2019
irinasolodova3
Суховодова599
АнжелаВасильевич
e-liza-k
Рузиев_Давиденко
bal4shovser16
elenabarskova7145
slipu817838
nata27-73589