Анна-Денис1346
?>

нужно написать 3 задачи1) Написать задачу: Обмен переменных значениями. (Пример: было: а=7, b= 2, стало:а=2, b= 7) Числа вы вводите с клавиатуры. 2)Напишите программу, которая получает с клавиатуры четырёхзначное натуральное число и переставляет его первую и последнюю цифры, например, из числа 1234 должно получиться число 4231. 3) Напишите программу, которая получает с клавиатуры два целых числа, а и b (a < b), и выводит на экран 5 случайных целых чисел на отрезке [a; b]. ​

Информатика

Ответы

koochma
Компьютер — самый необычный инструмент из всех придуманных человеком. Он используется не в материальной, а в умственной, интеллектуальной деятельности людей разных профессий: экономистов, конструкторов, переводчиков, психологов, физиков, художников...

Возможности своего интеллектуального человек постоянно старается расширить. Для этого не только совершенствуется оборудование, «железо» компьютера, но и создаются новые компьютерные программы, программные средства. Эти программы составляются программистами — специалистами в области информатики.


Зачем нужны компьютерные программы? Компьютер часто называют «умной» машиной, однако он не обладает человеческим разумом. Человек действует, когда захочет этого сам, или по заданию других людей. Компьютер ничего не делает «по собственному хотению». Все действия он выполняет только по заданию человека. Для управления действиями компьютера и предназначены компьютерные программы.

Могут ли программисты составлять компьютерные программы без участия других специалистов? Пусть, например, программа предназначена для авиаконструктора или модельера-парикмахера, тогда программисту потребуется представителей этих профессий. Только специалисты смогут подробно рассказать, с какими предметами, персонажами и явлениями они имеют дело в своей работе, что может происходить со всеми этими объектами, как принимаются решения. На месте такого специалиста может оказаться в будущем любой из вас, какую бы профессию он ни выбрал.

 Может ли человек, не изучавший информатику, рассказать о своей работе, учебе или любимой игре? Наверное, да. Но одно дело, когда рассказ предназначен для другого человека, и совсем другое, когда сведения нужны для создания компьютерной программы. Объясняя что-то людям, мы можем не вдаваться в какие-то подробности, полагаясь на их опыт, знания, сообразительность. В описаниях, которые составляются при создании компьютерных программ, не должно быть ничего лишнего, но в то же время они не могут полагаться на чей-то опыт или смекалку.

 И еще: эти описания нужно представить не в форме устного рассказа или повести, а в виде наглядных и компактных схем, таблиц, списков. Составлению таких «компьютерных» описаний нужно специально учиться — изучать информатику. Полученные знания и умения можно использовать не только при создании компьютерных программ. Они пригодятся всем, кому приходится составлять описания, инструкции, объяснения. А ведь делать это приходится практически каждому человеку — в любом возрасте и в самых различных ситуациях. 
Юлия-Ольга1313

Я не понял в первом задании что за переменная s написана в условии, вероятно там опечатка и должно быть написано переменной k, но да ладно...

Объяснение:

Задание 1

Алгоритм начинается с того, что переменной k присваивается значение 4

затем из строчки

for i := 1 to 3 do

мы понимаем, что переменная i последовательно принимает значение от 1 до 3 с шагом 1(то есть 1, 2 и 3), при каждом срабатывании алгоритма

При i равной 1 наш цикл запускается в первый раз и строчка

k := i + 2*k

ни что иное как

k := 1 + 2*4

то есть переменной k присваивается значение 9, затем цикл начинается заново, но переменная i уже имеет значение 2, а переменная k с раза заимела значение 9, тогда

k := 2 + 2*9

Теперь переменная k имеет значение 20, начинается 3й и последний цикл, где переменная i принимает значение 3, тогда

k := 3 + 2*20

И как итог переменная k примет значение 43, что программа и выведет на экран, согласно строчке

writeln(k)

Задание 2

Программа начинается с того, что переменным Dat[1...10] определённые значение, они указаны в самой программе и целесообразность их переписывания ещё раз стремится к 0

Затем переменной m присваивается значение 0 в строчке

m := 0

Затем начинается цикл for для переменной k, которая является просто номером переменной Dat[]

В этом цикле сравнивается значение переменной Dat[k] с переменной m и, в случае если значение переменной Dat[k] оказывается больше значения переменной m, то переменной m присваивается значение переменной Dat[k]

В первый раз мы сравниваем Dat[1]  (ранее мы Dat[1] присвоили значение 56) с m (изначально значение 0)

А так как 56 > 0, то переменной m присваивается значение 56

Это видно из следующих строчек кода:

     if Dat[k] > m then

     begin

     m := Dat[k];

     end;

Во второй раз мы работаем уже с переменной Dat[2] (Её значение равно 70)

А так как 70 > 56, то переменной m присваивается значение 70

Далее программа последовательно сравнивает все остальные переменные Dat[3...10], с переменной m, которая имеет значение 70, но так как ни одно из оставшихся значений переменной Dat[k] не превосходит 70, то переменная m больше не меняется, а значит на выходе программа выведет на экран число 70, которое соответствует значению переменной m, что можно увидеть в строчке

writeln(m)

Постарался максимально подробно... Но если планируешь сдавать ОГЭ по инфе, то лучше самому такие задачи решать, для начала скачав себе на ПК паскаль, переписывая туда код и потом думать почему ответ такой и как так вышло...

Удачи

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужно написать 3 задачи1) Написать задачу: Обмен переменных значениями. (Пример: было: а=7, b= 2, стало:а=2, b= 7) Числа вы вводите с клавиатуры. 2)Напишите программу, которая получает с клавиатуры четырёхзначное натуральное число и переставляет его первую и последнюю цифры, например, из числа 1234 должно получиться число 4231. 3) Напишите программу, которая получает с клавиатуры два целых числа, а и b (a < b), и выводит на экран 5 случайных целых чисел на отрезке [a; b]. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mir5552
nickcook424
potemkin77
skvorec3424
Galinagol559
narkimry134
puma802
funny-furiya
gladkihvv
annashaykhattarova1
themolodoy
ЕлизаветаВладимирович
Misyura_Viktoriya1683
lider123
akinin95
▲