andy74rus36
?>

Написать программу. Пользователь вводит целое число. Если оно является четным и находится между 30 и 40, то вывести на экран его куб. В противном случае написать исходное число. Написать программу. В компьютер вводится число. Если оно не находится между 30 и 40, то написать "Мимо", в противном случае "Попал".

Информатика

Ответы

ИП-Сысоев1628

#include <iostream>

int gg(int k, int p, double m)

{

p = (k >= p) ? p : p / k;

return (m * 2 * p);

}

int main()

{

int k, p;

double m;

std::cout << "Сколько котлет можно одновременно положить на сковороду ? ";

std::cin >> k;

std::cout << "Сколько минут жарится одна сторона котлеты ? ";

std::cin >> m;

std::cout << "Сколько котлет вы будете жарить ? ";

std::cin >> p;

std::cout << p << " котлет пожарятся с двух сторон минимум за " << gg(k, p, m) << " минут";

}

sav4ukoxana7149
Имеется всего 6 вариантов как назначить бакам целевой мусор. Например, в 1-й бак собираем стекло, во 2-й бак бумагу, в 3-й бак жесть. Другой вариант: в 1-й стекло, 2-й жесть, 3-й бумага. Всего имеется шесть таких вариантов.

Можем тупо перебрать эти варианты сборки из исходных данных, и увидеть который даст меньшую сумму перекладок. Можешь сделать это самостоятельно, а мне лень. 

Идём дальше, и заметим, что сумма перекладок составляет общую сумму всех предметов во всех баках, за минусом тех, которые изначально уже находятся в своих баках. Эта логика верна для любого из шести начальных вариантов.

А что такое предметы, уже находящиеся в своих баках? Это значит, что для данного из шести вариантов наборов баков имеется только одно число в своей строке таблицы, которое указывает на уже лежащий предмет. Например, если баки назначаем так: стекло, бумага, жесть, то из общей суммы всех предметов задачи нужно вычесть числа 52, 83, 75 - то есть лежащие на главной диагонали таблицы. 

Для нахождения решения задачи нам нужно подобрать такую перестановку столбцов заданной таблицы, чтобы сумма чисел, находящихся на главной диагонали была максимальной. При таком варианте общая сумма перекладок предметов будет минимальна.

Руководствуясь этим принципом, нужно найти такую комбинацию выбора трёх чисел из заданной таблицы, чтобы они все три одновременно принадлежали как разным строкам, так и разным столбцам; и при этом сумма выбранных чисел была бы максимальной из всех (а их 6) вариантов выбора.

Мне неохота перебирать все эти комбинации, сделай сам. Но навскидку кажется, что если из первого столбца выберу максимальное число (98), из второго столбца уже выбранную строку (вторую) трогать нельзя, поэтому среди верхнего (58) и нижнего (83) выберу наибольшее, и это 83. Таким образом, вторая и третья строки заняты. Из третьего столбца остаётся, что можно взять только число из первой строки, и это 64.

Сумма 98+83+64 = 245 - это число предметов, которые не нужно перекладывать, они сразу лежат в своих баках.

Общее число предметов в задаче - сумма всех 9 чисел таблцы, у меня получилась 693.

ответом будет число перекладок, равное общему числу предметов, минус которые не надо перекладывать. То есть 693 - 245 = 448.

Думаю что это и есть ответ. Но лучше проверь остальные 5 вариантов назначения баков своим видам мусора, и получишь ещё пять чисел. ответом будет наименьшее из них. Чисто нвскидку мне кажется, что это и будет 448.    

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу. Пользователь вводит целое число. Если оно является четным и находится между 30 и 40, то вывести на экран его куб. В противном случае написать исходное число. Написать программу. В компьютер вводится число. Если оно не находится между 30 и 40, то написать "Мимо", в противном случае "Попал".
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksandrovich_Mitoyan1138
yliana
Вячеславович-Дмитрий1694
jeep75
abroskin2002
artashhovhan
Irina1435
dream2366
baeva-larisa8165
horina12
alexeytikhonov
milkiev
zrs-546
oalexandrova75
Спиридонова