eurostom
?>

Нужна с задачей python Учительница задала школьникам сделать проект, за который можно получить от 3 до После чего она предложила им разделить эти на три оценки, каждая от 1 до 5. Коля получил за проект n и теперь думает, как их лучше всего разделить на три оценки. Он считает, что первая оценка меньше всего влияет на оценку в четверти, поэтому хочет разделить таким образом, чтобы сумма второй и третьей оценки была максимально возможной Коле разделить n на три оценки так, чтобы сумма второй и третьей оценки была максимальна. Входные данные Ввод содержит одно число n (3≤n≤15 Выходные данные Выведите три числа — разделение на оценки, при котором сумма второй и третьей оценки максимальна. Если решений несколько, выведите любое. Примеры входные данныеСкопировать 8 выходные данныеСкопировать 1 3 4 входные данныеСкопировать 14 выходные данныеСкопировать 4 5 5

Информатика

Ответы

Головин662

Ссожсжшажгазгажгаосомл

yuliasam

х=7690 - условие

var x, L, M: integer;

begin readln(x);

L:=0;

M:=0;

while x > 0 do begin

1) L:= L + 1 = 1;

M:= M + x mod 10 = 0;

x:= x div 10 = 7 69;

2) L:= L + 1 = 2;

M:= M + x mod 10 = 9;

x:= x div 10 = 7 6;

3) L:= L + 1 = 3;

M:= M + x mod 10 = 15;

x:= x div 10 = 7 ;

4) L:= L + 1 = 4;

M:= M + x mod 10 = 22;

x:= x div 10 = 0;

end;

writeln(L);

write(M);

end.

L = 4; M = 22

Объяснение:

1)L:= L + 1 = 0 + 1 = 1;

M:= M + x mod 10 = 0 + 0 (остаток) = 0;

x:= x div 10 = 7690 : 10 = 769 (остаток 0 здесь не пишется);

2)L:= L + 1 = 1 + 1 = 2;

M:= M + x mod 10 = 0 + 9 (остаток) = 9;

x:= x div 10 = 769 : 10 = 76 (остаток 9 здесь не пишется);

3)L:= L + 1 = 2 + 1 = 3;

M:= M + x mod 10 = 9 + 6 (остаток) = 15;

x:= x div 10 = 76 : 10 = 7 (остаток 6 здесь не пишется);

4)L:= L + 1 = 3 + 1 = 4;

M:= M + x mod 10 = 15 + 7 (остаток) = 22;

x:= x div 10 = 7 : 10 = 0 (остаток 7 здесь не пишется);

nadjasokolova2017
ответ:

1) 5

2) 0

3) 1

Объяснение:1) s:=0; for i:=10 downto 6 do s:=s+1;

Переменная s изначально равна 0. Потом идёт цикл от 10 вниз до 6, который каждый раз будет прибавлять к s единицу (s[новая] = s[старая] + 1). Цикл от 10 до 6 включительно, то есть он буде выполнятся 10-6+1=5 раз (+1 т.к. включительно). Получается мы 5 раз прибавляем к нулю 1. ответ: 0 + 1*5 = 5.

2)s:=0; for i:=8 to 3 do s:=s+1;

Переменная s изначально равна 0. Потом идёт цикл от 8 до 6, который выполнятся не будет, так как 8>6, и увеличиваясь на 1 каждый раз, он никогда не дойдет до 6. Для работы необходимо писать downto вместо to, то есть вниз до. Однако такового тут нет, поэтому цикл не выполняется и переменная s остаётся 0. ответ: 0.

3)s:=1; for i:=2 downto 10 dо s:=s+1;

Переменная s изначально равна 1. Потом идёт цикл от 2 вниз до 10, который выполнятся не будет, так как 2<10, и уменьшаясь на 1 каждый раз, он никогда не дойдет до 10. Для работы необходимо писать to вместо downto, то есть до, а не вниз до. Однако такового тут нет, поэтому цикл не выполняется и переменная s остаётся 1. ответ: 1.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужна с задачей python Учительница задала школьникам сделать проект, за который можно получить от 3 до После чего она предложила им разделить эти на три оценки, каждая от 1 до 5. Коля получил за проект n и теперь думает, как их лучше всего разделить на три оценки. Он считает, что первая оценка меньше всего влияет на оценку в четверти, поэтому хочет разделить таким образом, чтобы сумма второй и третьей оценки была максимально возможной Коле разделить n на три оценки так, чтобы сумма второй и третьей оценки была максимальна. Входные данные Ввод содержит одно число n (3≤n≤15 Выходные данные Выведите три числа — разделение на оценки, при котором сумма второй и третьей оценки максимальна. Если решений несколько, выведите любое. Примеры входные данныеСкопировать 8 выходные данныеСкопировать 1 3 4 входные данныеСкопировать 14 выходные данныеСкопировать 4 5 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ignateva737
verkop9
lider-mpl550
imosal
nunabat457
Chuhnin195107364
kisuhakisa
osipovasalex5316
kokukhin
Amulenkov
соловьев_Куркина
yurievaalxndra55
Nikolai710
annakuznetsova841
Валентинович133