PetrovnaTsukanov
?>

Задание по информатике Фирме принадлежат два магазина. Известна выручка в каждом магазине за каждый день в июле, данные о которых хранятся в двух массивах А и В(магазин А и магазин В Массивы А и В заполнить случайными двузначными числами. Получить общую стоимость вырученных фирмой денег за месяц

Информатика

Ответы

iraira761

program ostan;

var N,I,J,res: integer;

prov:real;

begin

writeln('Введите количество остановок на маршруте автобуса: ');

read(N);

writeln('Введите пункт отправления ');

read(I);

writeln('Введите конечную остановку ');

read(J);

//N должно быть >1, т.к. для корректного выполнения задачи у нас должно быть хотябы 2 остановки

//I<N+1; +1 для того, что I или J могут быть крайними

//I<>J означает I не равно J, т.к. если мы отправляемся на ту-же остановку, где мы сейчас находимся, ездить незачем

if ((N>1)and(I<N+1)and(J<N+1)and(I<>J)) then

begin

//Тут вводится переменная prov - проверка, как нам короче ехать, от меньшего к большему или в обратную сторону

prov:=N/2;

if (I<J) then if (prov>J-I) then res:=J-I-1 else res:=N-J+I-1 //если I<J, и если разница J-I < prov, то нам выгоднее ехать по прямой, если >, то в обратную сторону

else if (prov>I-J) then res:=I-J-1 else res:=N-I+J-1; // то-же самое, только для I>J

writeln();

writeln('Количество остановок между пунктами = ',res);

end

else writeln(); writeln('ДАННЫЕ НЕ КОРРЕКТНЫ, ОШИБКА ВВОДА');

end.

Хоть какая-то интересная задача на этом сервисе)

Wunkamnevniki13438

Избавься от ограничений

ПОПРОБУЙ ЗНАНИЯ ПЛЮС СЕГОДНЯ

fefeffewfe334131214

9 минут назад

Информатика

студенческий

ответ дан

И 100 РУБЛЕЙ НА КИВИ ИЛИ КАРТУ

Имеется делитель напряжения, на выходе которого напряжение рассчитывается по формуле: U=E∗R1/R2+R1 В наборе есть по одному резистору следующих номиналов (кОм): 1,1.2,3,3.3,4.7,5.1,6.8,9.1 При напряжении E=12В выбрать резисторы R1 и R2 таким образом, чтобы напряжение U было как можно ближе к 5В.

1

СМОТРЕТЬ ОТВЕТ

ДОБАВИТЬ ОТВЕТ

+18 Б.

Войди чтобы добавить комментарий

fefeffewfe334131214 ждёт твоего решения.

ответь на вопрос и заработай .

ответ

5,0/5

0

dofigapodpisotybezvi

новичок

1 ответ

1 пользователей, получивших

3.2

Объяснение:

Делитель напряжения используется в электрических цепях, если необходимо понизить напряжение и получить несколько его фиксированных значений. Состоит он из двух и более элементов (резисторов, реактивных сопротивлений). Элементарный делитель можно представить как два участка цепи, называемые плечами. Участок между положительным напряжением и нулевой точкой – верхнее плечо, между нулевой и минусом – нижнее плечо.

Делитель напряжения на резисторах может применятmся как для постоянного, так и для переменного напряжений. Применяется для низкого напряжения и не предназначен для питания мощных машин. Простейший делитель состоит из двух последовательно соединенных резисторов:

На резистивный делитель напряжения подается напряжение питающей сети U, на каждом из сопротивлений R1 и R2 происходит падение напряжения. Сумма U1 и U2 и будет равна значению U.

В соответствии с законом Ома (1):

Закон Ома

Падение напряжения будет прямо пропорционально значению сопротивления и величине тока. Согласно первому закону Кирхгофа, величина тока, протекающего через сопротивления одинакова. С чего следует, что падение напряжения на каждом резисторе (2,3):

Тогда напряжение на всем участке цепи (4):

Напряжение всей цепи

Отсюда определим, чему равно значение тока без включения нагрузки (5):

Величина тока

Если подставить данное выражение в (2 и 3), то получим формулы расчета падения напряжения для делителя напряжения на резисторах (6, 7):

Необходимо упомянуть, что значения сопротивлений делителя должны быть на порядок или два (все зависит от требуемой точности питания) меньше, чем сопротивление нагрузки. Если же это условие не выполняется, то при приведенном расчете подаваемое напряжение будет посчитано очень грубо

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание по информатике Фирме принадлежат два магазина. Известна выручка в каждом магазине за каждый день в июле, данные о которых хранятся в двух массивах А и В(магазин А и магазин В Массивы А и В заполнить случайными двузначными числами. Получить общую стоимость вырученных фирмой денег за месяц
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

andrew-lev2501
АльбертовичБерезин58
evolkova-73
Viktorovna_Yurevna
delonghisochi
elenalusia
smirnovaL1286
sergeevich
Golubitskaya378
amaraks67
bandurinei
yurassolo747
xalina85
mariyachervonnaya44
Makarov