Aleksandr740
?>

С использованием процедур и функций. 1. Напишите программу, которая находит все числа в диапазоне от a до b , сумма цифр которых не меняется при умножении на 2, 3, 4, 5, 6, 7, 8 и 9 (например, число 9 Используйте функцию для вычисления суммы цифр числа. Входные данные Входная строка содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b . Выходные данные Программа должна вывести все числа, удовлетворяющие условию, в одной строке, разделив их пробелами. Если таких чисел нет, нужно вывести число 0. Примеры входные данные 1 10 выходные данные 9 2. Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумме двух предыдущих: F i = F i - 1 + F i - 2 . Напишите программу, которая вводит натуральное число N и выводит первые N чисел Фибоначчи. Входные данные Входная строка содержит натуральное число N – количество нужных чисел Фибоначчи. Выходные данные Программа должна вывести в одной строке первые N чисел Фибоначчи, разделив их пробелами. Примеры входные данные 5 выходные данные 1 1 2 3 5 3. Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в заданную систему счисления с любым основанием от 2 до 36. Используйте процедуру. Входные данные Входная строка содержит целое число N и основание системы счисления B , разделённые пробелом. Гарантируется, что 2 ≤ B ≤ 36 . Выходные данные Программа должна вывести представление переданного её числа N в системе счисления с основанием B . При записи чисел в системах с основанием большим 10 используются прописные латинские буквы.

Информатика

Ответы

kurmaleeva

1)

def smm_numbers(x):

   sm = 0

   sm_num = 0

   for _ in x:

       sm += int(_)

   for j in range(2, 10):

       j = str(j * int(x))

       for p in j:

           sm_num += int(p)

       if sm_num != sm:

           return False

       sm_num = 0

   return True

a, b = map(int, input().split())

count = 0

for i in range(a, b + 1):

   if smm_numbers(str(i)):

       print(i)

       count += 1

if count == 0:

   print(0)

2)

def fib(n):

   if n == 0 or n == 1:

       return 1

   else:

       return fib(n - 1) + fib(n - 2)

for i in range(int(input())):

   print(fib(i), end=' ')

3)

alphabet = ''

def now_system_10(x):

   global new_system

   znak = '+'

   if x < 0:

       x = abs(x)

       znak = '-'

   new_x = ''

   lst = []

   while x >= new_system or lst == []:

       if 9 < x % new_system:

           if x % new_system < 20:

               lst += [alphabet[int(str(x % new_system)[1])]]

           elif x % new_system < 30:

               lst += [alphabet[int('1' + str(x % new_system)[1])]]

           else:

               lst += [alphabet[int('2' + str(x % new_system)[1])]]

       else:

           lst += [x % new_system]

       x //= new_system

   if x != 0:

       lst += [x]

   lst.reverse()

   if znak == '-':

       new_x += '-'

   for j in lst:

       new_x += str(j)

   return new_x

num, new_system = map(int, input().split())

print(now_system_10(num))

anaissite6
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
laplena1982750
1. Выразим выражения по правилам языка Pascal:
a) 5 * 2 - 4
Решение:
Умножение имеет более высокий приоритет, чем вычитание. Поэтому, сначала выполним вычисление умножения: 5 * 2 = 10.
Затем, выполним вычитание: 10 - 4 = 6.
Ответ: 6.

б) 7 * х + 2
Решение:
Умножение имеет более высокий приоритет, чем сложение. Поэтому, сначала выполним вычисление умножения: 7 * х = 7х.
Затем, выполним сложение: 7х + 2.
Ответ: 7х + 2.

в) 8 * х - 3 * (х + у)
Решение:
Выполним умножение: 8 * х = 8х и 3 * (х + у) = 3х + 3у.
Затем, выполним вычитание: 8х - (3х + 3у).
Для выполнения операции в скобках, умножение 3 на каждый из элементов внутри скобок:
8х - 3х - 3у = 5х - 3у.
Ответ: 5х - 3у.

г) v^2 * х * у^2 * х * у
Решение:
По правилам алгебры, умножение можно проводить в любом порядке.
Выполним умножение: v^2 * х = v^2х, у^2 * х = у^2х, v^2х * у^2х = (vх * у)^2х.
Ответ: (vх * у)^2х.

2. Переведем запись с языка Pascal в нормальную форму:
f = (3 * x + 4 * y)/(2 * sqr(к) - 4 * t / y)
Решение:
Нормализация выражения подразумевает разделение на более простые составляющие.
Заменим sqr(к) на к^2, чтобы выразить возведение в квадрат в общепринятой форме:
f = (3 * x + 4 * y)/(2 * к^2 - 4 * t / y)
Затем, выполним умножение и деление в числителе и знаменателе:
f = (3 * x + 4 * y)/(2к^2 - (4 * t) / y)
Ответ: f = (3 * x + 4 * y)/(2к^2 - 4t/y).

Таким образом, мы записали выражения по правилам языка Pascal и перевели запись с языка Pascal в нормальную форму.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С использованием процедур и функций. 1. Напишите программу, которая находит все числа в диапазоне от a до b , сумма цифр которых не меняется при умножении на 2, 3, 4, 5, 6, 7, 8 и 9 (например, число 9 Используйте функцию для вычисления суммы цифр числа. Входные данные Входная строка содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b . Выходные данные Программа должна вывести все числа, удовлетворяющие условию, в одной строке, разделив их пробелами. Если таких чисел нет, нужно вывести число 0. Примеры входные данные 1 10 выходные данные 9 2. Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумме двух предыдущих: F i = F i - 1 + F i - 2 . Напишите программу, которая вводит натуральное число N и выводит первые N чисел Фибоначчи. Входные данные Входная строка содержит натуральное число N – количество нужных чисел Фибоначчи. Выходные данные Программа должна вывести в одной строке первые N чисел Фибоначчи, разделив их пробелами. Примеры входные данные 5 выходные данные 1 1 2 3 5 3. Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в заданную систему счисления с любым основанием от 2 до 36. Используйте процедуру. Входные данные Входная строка содержит целое число N и основание системы счисления B , разделённые пробелом. Гарантируется, что 2 ≤ B ≤ 36 . Выходные данные Программа должна вывести представление переданного её числа N в системе счисления с основанием B . При записи чисел в системах с основанием большим 10 используются прописные латинские буквы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zaotar2008
Igorevich1559
werda84
vodolaz8384
troian07
shmanm26
kiravalter1998697
Герасимова107
Telenkovav
mrubleva42
Larisa-Andrei
bristolhouse20151001
voen-torg
Галстян874
Nadezhdachizhikova7968
▲