bksenia9775
?>

Напишите программу в Питоне(задачи, вторая картинка), которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. На примере того что снизу скинула...

Информатика

Ответы

btatarintsev

ответ A:

i = 0

n = int(input("Введите число: "))

while n != 0:

  if n % 3 == 0:

      i += 1

  n = int(input("Введите число: "))    

print("ответ: {}".format(i))

ответ Б:

i = 0

n = int(input("Введите число: "))

while n != 0:

  if (n % 10 == 3) and (n < 100 and n > 9):

      i += 1

  n = int(input("Введите число: "))    

print("ответ: {}".format(i))

ответ C:

i = 0

n = int(input("Введите число: "))

max = n

while n != 0:

  if n > max:

      max = n

  n = int(input("Введите число: "))    

print("ответ: {}".format(max))

boykovandrew6663
Первый большой):

использовать Чертежник
алг Богдан_1
нач
опустить перо
сместиться в точку(0, 11)
сместиться в точку(6, 11)
поднять перо
сместиться в точку(0, 6)
опустить перо
сместиться в точку(6, 6)
сместиться в точку(6, 0)
сместиться в точку(0, 0)
поднять перо
сместиться в точку(8, 0)
опустить перо
сместиться в точку(8, 11)
сместиться в точку(14, 11)
сместиться в точку(14, 0)
сместиться в точку(8, 0)
поднять перо
сместиться в точку(16, 0)
опустить перо
сместиться в точку(16, 11)
сместиться в точку(22, 11)
поднять перо
сместиться в точку(22, 0)
опустить перо
сместиться в точку(22, -2)
сместиться в точку(22, 0)
сместиться в точку(30, 0)
сместиться в точку(30, -2)
сместиться в точку(30, 0)
сместиться в точку(28, 0)
сместиться в точку(28, 11)
сместиться в точку(24, 11)
сместиться в точку(24, 0)
поднять перо
сместиться в точку(32, 0)
опустить перо
сместиться в точку(32, 11)
сместиться в точку(38, 11)
сместиться в точку(38, 0)
сместиться в точку(38, 5)
сместиться в точку(32, 5)
поднять перо
сместиться в точку(40,0)
опустить перо
сместиться в точку(40, 11)
сместиться в точку(40, 5)
сместиться в точку(46, 5)
сместиться в точку(46, 11)
сместиться в точку(46, 0)
кон

Второй короткий):

использовать Чертежник
алг Богдан_2
нач
написать(30, "Богдан")
кон

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в Питоне(задачи, вторая картинка), которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. На примере того что снизу скинула...
Ваше имя (никнейм)*
Email*
Комментарий*