artem
?>

На Найди самого большого. Пользователь вводит последовательность целых чисел (каждое число на новой строке Если пользователь вводит 0, то последовательность заканчивается. Напишите программу, которая будет считать индекс (порядковый номер) самого большого числа. Подсказка: первое введенное число сначала является самым большим. Потом ситуация может поменяться. Мы принимаем новые числа ПОКА новое число не равно нулю. Пример входа №1: 9 8 7 6 0 Пример результата №1: 1 Пример входа №2: 1 2 3 2 1 0 Пример результата №2: 3

Информатика

Ответы

roman-fetisov2005

l = list()

print("Вводите числа, 0 - остановка.")

while True:

   n = int(input())

   if n == 0:

       break;

   l.append(n)

maxInt = max(l)

print("Индекс максимального числа:" + str(l.index(maxInt)))

Объяснение:

При первом запуске я ввел максимальное число - 9, программа сказала, что индекс этого числа - 0. Почему? В языке Python нумерация списков начинается с нуля.


На Найди самого большого. Пользователь вводит последовательность целых чисел (каждое число на новой
ekasatkina

Задача 1

var

 y, x: integer;// Объявляем переменные типа Integer

begin// Начало блока

 writeln('Введите X: '); //Выводим текст на экран

 read(x); //Читаем значение введеное с кливиатуры и записываем его в переменную

 y := 7 * x * 2 - 3 * x + 6; //Выолняем выражение

 writeln('Результат: ', y);// Выводим результат

end. // конец блока

Задача 2:

var

 a, b, c: integer;//Объявление переменных

begin

 write('Введите длину ребра куба '); //Вывод текста на экран

 read(a); //Читаем значение введеное с клавиатуры

 b := a * a * a; //Вычисляем объем куба

 c := 6 * sqr(a); //Sqr - квадрат числа

 {Далее опять же вывод результата}

 writeln('Объём куба равен ', b);

 writeln('Площадь боковой поверхности куба равна ', c);

end.

Задача 3

var

 k: integer;//Объявление переменных

begin

 write('Введите число: '); //Вывод текста на экран

 read(k); //Читаем значение введное с клавиатуры

 if Odd(k) then //Odd - возвращает True - если значение нечетно и False если четно

   writeln('Нечетное')

 else

   writeln('Четное');

end.

Задача 4:

var

 a, b: integer;

begin

 writeln('Введите a и b через пробел:');

 readln(a, b);

 if (b mod a = 0) then writeln('Число ', a, ' является делителем числа ', b)  

 else writeln('Число ', a, ' НЕ является делителем числа ', b);

end.

Задача 5:

var

 a, b: real;

begin

 writeln('Через пробел введите 2 числа: ');

 read(a, b);

 if a > b then //Условие если А больше Б

 begin

   a := a / 2; //Делим число А на 2 и выводим результат

   writeln('A:= ', a, ' B:= ', b);

 end

 else //Иначе оставляем все как и было

   writeln('A:= ', a, ' B:= ', b);

end.

vladai2

Ctrl + 1 Переключиться в режим библиотеки Из любого режима

Ctrl + 2 Переключиться в режим скина Из любого режима

Ctrl + 3 Переключиться в режим плеера Из любого режима, исключая полно-экранный

Ctrl + 7 Добавить в список проигрывания В режиме библиотеки

Ctrl + 8 Добавить в список записи В режиме библиотеки

Ctrl + 9 Добавить в список синхронизации В режиме библиотеки

Ctrl + A Выбрать все элементы в списке В библиотеке или списке

Ctrl + B Предыдущий (элемент или раздел) При проигрывании контента

Ctrl + E Сфокусироваться на поиске и перейти в режим библиотеки, если еще не в нем

Ctrl + F Следующий (элемент или раздел) При проигрывании контента

Ctrl + H Включить/выключить режим случайного выбора shuffle mode

Ctrl + J Извлечь В любом режиме

Ctrl + M Переключить меню в библиотеке В любом режиме

Ctrl + N Создать плейлист (список проигрывания) В режиме библиотеки

Ctrl + O Показать диалог открытия В любом режиме

Ctrl + P Переключатель проигрывания / паузы Контента в очереди

Ctrl + Q Добавить выбранный трэк в открытый список По умолчанию в списке проигрывания

Объяснение:

их пипец как много я написала что знаю

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На Найди самого большого. Пользователь вводит последовательность целых чисел (каждое число на новой строке Если пользователь вводит 0, то последовательность заканчивается. Напишите программу, которая будет считать индекс (порядковый номер) самого большого числа. Подсказка: первое введенное число сначала является самым большим. Потом ситуация может поменяться. Мы принимаем новые числа ПОКА новое число не равно нулю. Пример входа №1: 9 8 7 6 0 Пример результата №1: 1 Пример входа №2: 1 2 3 2 1 0 Пример результата №2: 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gsktae7
карпова581
Artak96993298
mishagoride885
mereninka7008
Игоревна
Nastyakarysheva8750
kolefe22171
Aivazyan
sotrudnik3
ВладимировнаИП37
d2904
glebshramko
Vasilevskii
inessa12006
▲