ksuhova
?>

В паскале авс.Напишите программу, которая в последовательности натуральных чисел определяет количество четных чисел. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность​

Информатика

Ответы

Kozloff-ra20146795

достоинства растровой графики:  

растровая графика предоставляет возможность создавать любые изображения не обращая внимание на сложность их исполнения в отличие от векторной графики, которая неспособна предать хорошо переход цветов от одного к другому.

широкий спектр применения – растровая графика на сегодняшний день нашла широкое применение в различных областях, от мелких изображений (иконок) до крупных (плакатов).

высокая скорость обработки изображений различной сложности, при условие что нет необходимости в их масштабирование.

представление растровой графики является естественным для большинства устройств и техники ввода-вывода графики.

недостатки растровой графики:

большой размер файлов с простыми растровыми изображениями.

невозможно увеличение изображения в масштабе без потери качества.

вывод изображения при печати на плоттер является затруднительным.

при хорошем качестве изображения требуются значительный объем дискового пространства для хранения файлов.

сложность преобразования растрового изображения в векторное.

исходя из вышеуказанных недостатков хранить простые рисунки рекомендуется не в сжатой растровой графике, а использовать векторную.

достоинства векторной графики:

масштабирование размеров без потери качества изображения.

масштабированные изображения не увеличиваются в весе ни на один байт.

во время масштабирования качество, резкость, четкость и цветовые оттенки изображений не .

вес изображения в векторном формате в разы меньше веса изображения в растровом формате.

при конвертации изображения из векторного формата в растровый, не возникает никакой сложности.

толщина линий при изменение масштаба (увеличение или уменьшение) объектов может не изменяться.

недостатки векторной графики:

в векторной графике можно изобразить далеко не каждый объект. объем памяти и интервал времени на отображение векторной графики зависит от количества объектов и их сложности.

после преобразование из растрового изображения в векторное, обычно качество векторного изображения не высокое.

я думаю она нужна.

spz03

На паскале

program zadanije_tri;

var a, b, c:integer;

begin

 writeln('Введите первое число.');

 readln(a);

 writeln('Введите второе число.');

 readln(b);

 if a=b then

   begin

   c:=a*a+b*b;

   writeln('Введённые числа равны, сумма их квадратов равна ',c,'.');

   end

 else

   begin

   c:=(a+b)*(a+b);

   writeln('Введённые числа не равны, квадрат их суммы равен ',c,'.');

   end

end.

Объяснение:

Если ввести равные ЦЕЛЫЕ числа, то программа выдаст сумму их квадратов, если ввести разные числа, то программа выдаст квадрат их суммы.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В паскале авс.Напишите программу, которая в последовательности натуральных чисел определяет количество четных чисел. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sazhina1356
ekaterinkat
sergeykvik13
vetviptime
TSKaraulova
alina Korneev
Белов_Лукина1339
Mariya Filippov
lovely138887
Попов1946
rechkai64
yuip2008
eeirikh
хаджимурод1172
Владимирович_Намик59
▲