TSKaraulova
?>

Написать программу.задать три массива размерностью 10 элементов каждый, задать произвольным значения для двух массивов. элементам третьего массива присвоить произведение элементов первых двух. c[1]: =a[1]*b[1] c[2]: =a[2]*b[2] c[3]: =a[3]*b[3]

Информатика

Ответы

SitnikovYurii5
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(10, -50, 50);

 a.Println;

 var b := ArrRandom(10, -50, 50);

 b.Println;

 var c := a.Zip(b, (p, q)-> p * q).ToArray;

 c.Println

end.


Написать программу.задать три массива размерностью 10 элементов каждый, задать произвольным значения
Мамедов

Пояснення:В качестве кандидатов нужно рассматривать числа, не превышающие  

(

S

1

)

2

, так как в худшем случае составное число вида  

x

2

будет иметь два наибольших делителя  

x

и 1. Время работы этого алгоритма  

O

(

S

4

)

. Можно существенно ускорить вычисления, если учесть, что при поиске разложения на множители числа  

N

можно рассмотреть только числа не превышающие  

N

. Наибольшим делителем числа  

N

будет  

N

a

, где  

a

– наименьший делитель, а вторым наибольшим делителем будет либо  

N

b

, где  

b

– второй по величине делитель  

N

(также либо число, либо  

a

2

), либо  

a

, если  

N

является произведением двух различных чисел, либо 1, если  

N

=

a

2

.

Doronin755
Задача 1
var
x,y:integer;
begin
  writeln('Введите х');
  readln(x);
  writeln('Введите y');
  readln(y);
  if x<y then writeln('Меньшее: ',x) else
  if x>y then writeln('Меньшее: ',y) else
  if x=y then writeln('Числа равны')
end.

задача 2
var
x,y:integer;
begin
  writeln('Введите первое число');
  readln(x);
  writeln('Введите второе число');
  readln(y);
  if y=0 then writeln('Второе число равно 0. Деление невозможно!') else
  writeln(x,'/',y,'=',x/y);
end.

задача 3
var
s,name:string;
begin
  writeln('Введите ваше имя');
  readln(name);
  writeln('Введите строку');
  readln(s);
  if s=name then writeln('Привет!') else
  writeln('Здравствуйте!');
end.

задача 4
var
x:integer;
begin
  writeln('Введите число');
  readln(x);
  if (x mod 2)=0 then writeln('Четное') else writeln('Нечетное')
end.

задача 5
var
x:string;
i:integer;
begin
  writeln('Введите строку');
  readln(x);
  writeln('Введите номер символа');
  readln(i);
  if i > length(x) then writeln('Нет символа!') else writeln(x[i])
end.

задача 6
var
x,y:integer;
begin
  writeln('Количество яблок:');
  readln(x);
  writeln('Количество апельсинов:');
  readln(y);
  if (x*100)>(y*150) then writeln('Берите яблоки')
  else
  if (x*100)<(y*150) then writeln('Берите апельсины')
  else
  if (x*100)=(y*150) then writeln('Вес яблок и апельсинов одинаковый')
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу.задать три массива размерностью 10 элементов каждый, задать произвольным значения для двух массивов. элементам третьего массива присвоить произведение элементов первых двух. c[1]: =a[1]*b[1] c[2]: =a[2]*b[2] c[3]: =a[3]*b[3]
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stendpost
Nikolaevna Malika1511
VadimovichSvetlana622
лукашова940
Mashkov-Daniil1764
Reginahappy
Dmitrievich-Telishev
Moroshkina-Aristova2011
phiskill559
kate281078
Isaeva_Marin1010
purbuevat56524
natalili32
Жуков219
adminaa