Aleksandrovich-Mayatskikh
?>

3. Напишите программу по блок-схеме.a, b, c)Даa >b иa> сНетСообщить аДаНетb>сСообщить ЬСообщить с

Информатика

Ответы

Vladstreletskiy

pascal

Объяснение:

var

 a, b, c: integer;

begin

 Write('Введите a,b и c : ');

 ReadLn(a, b, c);

 if (a > b) and (a > c) then WriteLn(a)

 else if b > c then WriteLn(b)

     else WriteLn(c);

end.

orbbsvsupply

1) SketchUp

программы подсказывать наиболее удобный следующий ход и действия -  в любой момент построений он выводит на экран  графические и текстовые подсказки (левый нижний угол), опираясь на которые можно легко и быстро работать

Еще одна "фишка" SketchUp - панель VCB (Value control box) , это единственная числовая шкала на всем рабочем столе, она расположена в правом нижнем углу экрана.  

VCB выполняет две функции:

2.1 контроль за текущими действиями - редактируя, или создавая обьект, можно видеть величину его изменения в реальном времени

2.2 вводя точные числа в окошко после примерного выполнения действия, легко создавать идеально точные обьекты - для ввода в VCB не нужно наводить курсор на окошко, числа автоматически считываются с клавиатуры, так экономятся драгоценные секунды, что очень ценно в наш торопливый век

4) Интерфейс программы минималистичен настолько что напоминает детскую игрушку, но это обманчивое впечатление, на самом деле возможности SketchUp весьма широки, достаточно посмотреть на модели, которые делают профессионалы

8) Повышения качества моделей в определенных сферах, например архитектура.

9) Любительское создание графики

Объяснение:

Наталья_Владимир708
Цикл с предусловием это такой цикл, в котором условие проверяется перед выполнением тела цикла.
А цикл с постусловием - на оборот, он сначала выполнит, а потом проверит условие и если условие true, то цикл завершится.

Цикл с постусловием, можно использовать в таких ситуациях, когда надо что-то сделать и если чего-то не хватает, то сделать еще раз. Напрмер отправить письмо на email, а если не отправилось, то повторить еще 3 раза. Сначала выполнится тело цикла, в котором находятся функции отправки письма и если отправка удачная, то сообщаем until() true. Иначе тело выполнится еще и еще и еще кучу раз, если мы не задали счетчик в теле цикла, как вариант...

Цикл с предусловием можно использовать, если надо проверять какое-то значение ПЕРЕД выполнением тела цикла и тебе не важно, должно ли оно хоть раз выполниться. Например запросить пароль у пользователя. Но если пользователь уже ввёл пароль, то зачем его запрашивать? Тут можно было бы использовать while

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

3. Напишите программу по блок-схеме.a, b, c)Даa >b иa> сНетСообщить аДаНетb>сСообщить ЬСообщить с
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Grishanin
gabbro19975650
expozition
pwd10123869
Александр1991
Мария
puchkovajulia
myxa120283
baltgold-m27
Mnatsovna
mpityk
kondrashovalf6404
Новицкий1107
АлександрАлина
david-arustamyan1