andre6807
?>

Напишите программу, которая выводит среднее арифметическое и сумму пяти чисел. Пайтон

Информатика

Ответы

ski89439

s = 0

sr = 0

for i in range(5):

   i = int(input())

   s += i

   sr += i

print('Среднее арифметическое равно', str(sr/5))

print('Сумма равна', s)

ghjcnjtyjn64

ответ: перебор всегда работает но возможно не рационален

int main()

{

SetConsoleCP(1251);// установка кодовой страницы win-cp 1251 в поток ввода

SetConsoleOutputCP(1251); // установка кодовой страницы win-cp 1251 в поток вывода

setlocale(LC_ALL, "Russian");

int mass[4][5];

int max = 0;

int count = 0;

for (int i = 0; i < 3; i++)

{

 for (int j = 0; j < 4; j++)

 {

  mass[i][j] = rand() % 5;

  cout << mass[i][j] << " ";

 }

 cout << endl;

}

for (int i1 = 0; i1 < 3; i1++)

{

 for (int j1 = 0; j1 < 4; j1++)

 {

  for (int i = 0; i < 3; i++)

  {

   for (int j = 0; j < 4; j++)

   {

    if (mass[i1][j1] == mass[i][j])

    {

        count++;

    }

   }

   if ((count > 1) && (mass[i1][j1] >= max))

   {

    max = mass[i1][j1];

   }

   count = 0;

  }

 }

}

cout << endl << max;

Сергеевна-Пузанов

1 string - тип данных строка (любые символы), используются при наборе текста.

integer - тип данных число(цифры), используется ТОЛЬКО цифры.

2 Общий формат - это string (в нужных программах). Например при вводе года рождения пользователя

3 Конкатенация - формат типа integer в string. В некоторых языках программирования это важно. Например python

4 Числовой тип, только цифры. Текстовой любой тип. Формула в Excel это алгоритм выполнения функции. Формула начинается со знака "=".

Используется знаки *, /, : ,+, ^

5 пункта нету

6 Относительный ссылки, чтобы сделать относительную ссылку нужно перед буквой или цифрой поставить знак "$". Чтобы при протягивании формулы по клетками, в формуле автоматически не менялось, то значение, перед котлрым стоит знак "$"

7 Относительная ссылка - "$B3-D1"

Абсолютная ссылка - "B3 -D1"

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая выводит среднее арифметическое и сумму пяти чисел. Пайтон
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

margusha1974
yurogov61
Валерьевна1601
yrgenson2011801
fullhouse9991
iraimironova
oksit
TSKaraulova
petrova-kate3
pryvalovo48
Сергей
byfetvostochniy
Kamil
ashantik
rayon14