topshopnails
?>

1. Какие значения может принимать целая переменная Y, если в программе записано:Y:=10+random(5)? 2. Используя функцию random(x), получите числа в диапазонах:от 1 до 10, от -10 до +10, от 50 до 100. 3. Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. 4.Заполните случайными числами в диапазоне от 1 до 5 два массива:A [1:20] и B [1:20]. Найдите и выведите на экран только те элементы этих массивов, значение которых совпадают. Например, если A [2]=B [2]=4, то на экран надо вывести: Номер:2 значение:4 5.Придумайте свои получения этих чисел.

Информатика

Ответы

Yevgenevich_Chipura-Nikolaeva

1) От 10 до 14

2) random(1, 10); random(-10,10); random(50,100);

3)

var a:array[1..100] of integer;

   i, p, o:integer;

begin

 p := 0;

 o := 0;

 for i := 1 to 100 do

   a[i] := random(-20, 20);

 writeln(a);

 for i := 1 to 100 do begin

   if a[i] >= 0 then p := p + 1

   else o := o + 1;

 end;

 writeln('Положительных: ' + p);

 writeln('Отрицательных: ' + o);

end.

4)

var a:array[1..20] of integer;

   b:array[1..20] of integer;

   i:integer;

begin

 randomize;

 for i := 1 to 20 do

   begin

   a[i] := random(1, 5);

   b[i] := random(1, 5);

   end;

 for i := 1 to 20 do begin

   if a[i] = b[i] then begin

   writeln('Номер: ' + i);

   writeln('Значение: ' + a[i]);

   end;

 end;

end.

alekseisamohvolov7

n = int(input('Введите количество элементов массива: '))

a = [int(input("Введите элемент массива: ")) for i in range(n)]

k = int(input("Введите любое число: "))

m = 0

for i in a:

   if i == k:

       m = m + 1

if m == 0:

   print ("NO")

else:

   print ("YES")

Объяснение:

Я немного подправила программу по синтаксису(были ошибки). А ещё не поняла, что нужно сделать, но вот два теста:

ТЕСТ 1:

ВВОД:

Введите количество элементов массива: 2

Введите элемент массива: 2

Введите элемент массива: 2

Введите любое число: 12

ВЫВОД ПРОГРАММЫ:

NO

ТЕСТ 2:

ВВОД:

Введите количество элементов массива: 2

Введите элемент массива: 12

Введите элемент массива: 12

Введите любое число: 12

ВЫВОД ПРОГРАММЫ:

YES

zoomagazinkotmatroskin

мне кажется что это Pascal

Объяснение:

Ключевые особенности PascalABC.NET

Ряд расширений языка Pascal, в числе которых оператор foreach, внутриблочные описания переменных, автоопределение типа при описании, встроенные множества произвольных типов, case по строкам, упрощенный синтаксис модулей, методы в записях, операция new для создания объектов, определение тел методов внутри классов, целые произвольной длины, многомерные динамические массивы.

Самые современные средства языков программирования: обобщенные классы и подпрограммы, интерфейсы, перегрузка операций, λ-выражения, исключения, сборка мусора, методы расширения, безымянные классы, автоклассы.

Генерация эффективного кода для платформы .NET.

Высокая совместимость с Delphi.

Высокая скорость выполнения программ.

Возможность доступа к огромному количеству .NET-библиотек от контейнерных классов до средств работы с сетью.

Среда разработки с встроенным отладчиком, обеспечивающая подсказки по коду, переход к определению и реализации подпрограммы, шаблоны кода, автоформатирование кода.

Встроенный в среду разработки дизайнер форм для быстрого создания оконных приложений.

Простые и эффективные графические библиотеки (растровая, векторная и трёхмерная) для создания простых визуализаций и анимаций.

Средства параллельного программирования в виде директив OpenMP.

Встроенный электронный задачник Programming Taskbook.

Модули исполнителей Робот и Чертежник, используемых в школьной информатике.

Механизм проверяемых заданий, обеспечивающий автоматическую постановку и проверку заданий.

Возможность запуска консольного компилятора под Mono в современных версиях Linux, возможность встраивания PascalABC.NET в редактор Geany.

Система PascalABC.NET является совместной разработкой российских и немецких программистов. В России центр разработки находится в институте математики, механики и компьютерных наук Южного федерального университета.

PascalABC.NET активно используется в ряде средних и высших учебных заведений России и ближнего зарубежья. Так, на мехмате Южного федерального университета он используется для обучения 1 курса направления Фундаментальная информатика и информационные технологии в курсе Основы программирования, а также для обучения школьников в одной из самых больших в России Детской компьютерной школе.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Какие значения может принимать целая переменная Y, если в программе записано:Y:=10+random(5)? 2. Используя функцию random(x), получите числа в диапазонах:от 1 до 10, от -10 до +10, от 50 до 100. 3. Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. 4.Заполните случайными числами в диапазоне от 1 до 5 два массива:A [1:20] и B [1:20]. Найдите и выведите на экран только те элементы этих массивов, значение которых совпадают. Например, если A [2]=B [2]=4, то на экран надо вывести: Номер:2 значение:4 5.Придумайте свои получения этих чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Veselova
Ольга1915
Оздоевский
des-32463
Natalya1895
katdavidova91
Роман_Гречина
Мария
syana80
nadejdashin508
fedorenkoroman
Bella Sergei
Popova838
manager6
phmad7