gullieta
?>

Дан массив, состоящий из N целых чисел, количество элементов вводится с клавиатуры. Составить программу, в которой будут реализованы следующие действия: а) заполнение массива случайными числами и вывод полученного массива на экран; б) подсчет количества тех элементов массива, значения которых больше заданного числа x (вводит пользователь с клавиатуры) и одновременно кратны 5;

Информатика

Ответы

Petrakova Ilyushin

#include <iostream>

#include <math.h>

#include <conio.h>

#include <locale.h>

using namespace std;

int main()

{

   setlocale(LC_CTYPE, "");

   double  a, b, c;

   cout << "a = "; cin >> a; cout << endl;

   cout << "b = "; cin >> b; cout << endl;

   cout << "c = "; cin >> c; cout << endl;

   if ((a >= b + c) || (b >= a + c) || (c >= a + b))

   {

       cout << "Это не треугольник" << endl;

   }

   else if (a*a + b*b == c*c)

   {

       cout << "Это прямоугольный треугольник" << endl;

   }

   else if ((a*a + b*b > c*c) && (a*a + c*c > b*b) && (c*c + b*b > a*a))

   {

       cout << "Это остроугольный треугольник" << endl;

   }

   else

   {

       cout << "Это тупоугольный треугольник";

   }

       system("pause");

   return 0;

}

Объяснение:

elhovskoemodk

Решение.

1. Запишем числа маски сети в двоичной системе счисления:

 

25510 = 111111112

24810 = 111110002

010 = 000000002

 

2. Адрес сети получается в результате поразрядной конъюнкции чисел маски и чисел адреса узла (в двоичном коде). Так как конъюнкция 0 с чем-либо всегда равна 0, то на тех местах, где числа маски равны 0, в адресе узла стоит 0. Аналогично, там, где числа маски равны 255, стоит само число, так как конъюнкция 1 с любым числом всегда равна этому числу.

3. Рассмотрим конъюнкцию числа 248 с числом 243.

24810 = 111110002

24310 = 111100112

Результатом конъюнкции является число 111100002 = 240.

 

4. Сопоставим варианты ответа получившимся числам: 216, 23, 240, 0.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив, состоящий из N целых чисел, количество элементов вводится с клавиатуры. Составить программу, в которой будут реализованы следующие действия: а) заполнение массива случайными числами и вывод полученного массива на экран; б) подсчет количества тех элементов массива, значения которых больше заданного числа x (вводит пользователь с клавиатуры) и одновременно кратны 5;
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cheberyako2013
Semenova
Илья_Ветклиники1655
mariya
bolosolo77
DzukaevAlekseevich
memmedovallahverdi0239
Елена_Зайкин1665
Batrakova-Anna
Anatolevich-sergeevna
arnaut-anna
navi35374
Valentina
Verakravez8790
vshumilov