Olga-Borisovna
?>

Написать программу на Паскаль. Даны два числа.Если сумма этих чисел больше 10, то первое число возвести в квадрат, а второе увеличить на 10, в противном случае оставить числа без изменения. Вывести эти числа

Информатика

Ответы

alekseev13602

привет, программа на фото


Написать программу на Паскаль. Даны два числа.Если сумма этих чисел больше 10,то первое число возвес
zuelv

day=0

        p=N

        v=1

        поки p>0

        пц

                p=p-v

                v=v*2

                day= day+1

        кц

  Програма матиме вигляд:

         #include <iostream>

        using namespace std;

        int main(int argc, char** argv)  

        {

            int N, day, p, v;

            cin>>N;

            day=0;

            p=N;

            v=1;

            while (p>0)

            {

                p=p-v;

                v=v*2;

                day++;

             }

            cout<<day;

            return 0;

        }

Таблиця виконання алгоритму

Объяснение:

sergeevna

Python – багатоцільова мова програмування, яка дозволяє писати код, що добре читається. Відносний лаконізм мови Python дозволяє створити програму, яка буде набагато коротше свого аналога, написаного на іншій мові.

Python - багатоплатформова мова програмування. Це означає, що програми на Python можна запускати в різних операційних системах без будь-яких змін.

Ще однією перевагою Python є його стандартна бібліотека, яка встановлюється разом з Python і містить готові інструменти для роботи з операційною системою, веб-сторінками, базами даних, різними форматами даних, для побудови графічного інтерфейсу програм тощо.

Програми, написані на мові програмування Python, можуть бути як невеликими скриптами, так і складними системами.

Python абсолютно безкоштовний.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на Паскаль. Даны два числа.Если сумма этих чисел больше 10, то первое число возвести в квадрат, а второе увеличить на 10, в противном случае оставить числа без изменения. Вывести эти числа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksei1463
pbttehnology
araqsyabadalyan1988
manager9
arbat
vikanikita
михаил
slspam
zotovinbox468
mihailpolehin8
Bologova Golovach1989
Хромов1501
Рогова Ольга1156
magichands68
Lesya