Мария Кашихина
?>

Написать программу , которая выведет в столбик квадраты чисел от 15 до 35 в приложении кумир

Информатика

Ответы

Sacharov84
ПОСЛЕДОВАТЕЛЬНОСТЬ ФИБОНАЧЧИ, математическая ПОСЛЕДОВАТЕЛЬНОСТЬ, каждый член которой является суммой двух предыдущих. Таким образом, если энный член последовательности обозначается хn, то для всей последовательности справедливым будет уравнение: хn+2=хn+хn+1, первыми двумя членами которого будут x1=l и x2=1. Порядок последовательности при этом таков: 1, 1, 2, 3, 5, 8, 13, 21..., следующим числом будет 34, т. к. сумма 13 и 21 равна 34 и т.д. Когда число n становится очень большим, отношение соответствующих членов устремляется к величине (Ц5+l)/2. Это соотношение называется золотым. В природе последовательность Фибоначчи можно проследить на примерах спирального развития сегментов раковины и лепестков подсолнуха, расходящихся лучами из одной точки в центре цветка. см. также ЗОЛОТОЕ СЕЧЕНИЕ. 
Лилин1079
Var
n,t,s,d,e:integer;
begin
writeln('');
repeat
writeln('Введите сумму в рублях<=1000');
readln(n);
until (n>0) and (n<=1000);
t:=n div 1000;
n:=n-t*1000;
s:=n div 100;
n:=n-s*100;
d:=n div 10;
if d<>1 then
begin
n:=n-d*10;
e:=n;
end;
case t of
     1:write('тысяча ');
end;
if s>=0 then
case s of
     1:write('сто ');
     2:write('двести ');
     3:write('триста ');
     4:write('четыресто ');
     5:write('пятьсот ');
     6:write('шестьсот ');
     7:write('семьсот ');
     8:write('восемьсот ');
     9:write('девятьсот ');
end;
if d>=0 then
case d of
     1:
     case n of
     10: write('десять ');
     11: write('одиннадцать ');
     12: write('двенадцать ');
     13: write('тринадцать ');
     14: write('четырнадцать ');
     15: write('пятнадцать ');
     16: write('шестнадцать ');
     17: write('семнадцать ');
     18: write('восемнадцать ');
     19: write('девятнадцать ');
     end;
     2:write('двадцать ');
     3:write('тридцать ');
     4:write('сорок ');
     5:write('пятьдесят ');
     6:write('шестьдесят ');
     7:write('семьдесят ');
     8:write('восемьдесят ');
     9:write('девяносто ');
end;
if e>=0 then
case e of
     1:write('один ');
     2:write('два ');
     3:write('три ');
     4:write('четыре ');
     5:write('пять ');
     6:write('шесть ');
     7:write('семь ');
     8:write('восемь ');
     9:write('девять ');
end;
if (e=1) then write('рубль ')
else if (e=0)or(e>4) then write('рублей ')
else write('рубля ');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу , которая выведет в столбик квадраты чисел от 15 до 35 в приложении кумир
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

praktikadok
mstrshulz
tumanowivan2015509
Анатольевич
klodialeit36
ivanovanata36937365
konstantinslivkov
Марина Федорович924
oksanamalakhova004610
Bi-1704
druzjkinaas22
supercom-ru-marinaguseva4267
syana80
AndreevManaeva
PivovarovaIlina1437