poiskmarina
?>

Можете у кого с информатикой хорошо? Нужно написать две программы на языке Паскаль: 1)Дан одномерный массив целых чисел А[10]. Написать программу, реализующую поиск минимального элемента в массиве, затем организовать замену всех одинаковых минимальных значений на 0. 2)В массиве размерностью N содержатся целые числа, вычислить сумму четных положительных элементов.

Информатика

Ответы

sttig
1)
var s:string; i:integer;
begin
readln(s);
for i:=1 to length(s) do
 if (i mod 2=1)and(s[i]='н') then writeln(i,' - н');
end.

Пример:
Дано предложение. Вывести "столбиком" все его буквы н, стоящие на нечетных местах
3 - н
53 - н
67 - н

2)
var s,s1,s2:string;
begin
s:='вертикаль';
s1:=s[4]+s[5]+s[3];
s2:=s[1]+s[2]+s[4]+s[6]+s[7];
writeln(s1,' ',s2);
end.

Результат:
тир ветка

3. Замечание. Предполагается, что слова в предложениях отделяются друг от друга одним пробелом.
3 а)
var s:string; i,k:integer;
begin
readln(s);
k:=0;
for i:=1 to length(s) do
 begin
 if (s[i]='а')and(k=0) then
  begin s[i]:='о'; k:=1; end;
 if s[i]=' ' then k:=0;
 end;
writeln(s);
end.

Пример:
Напечатать все его слова, предварительно преобразовав каждое из них по правилу
Нопечатать все его слово, предворительно преоброзовав кождое из них по провилу

3 б)
var s,sl,s_new:string; i:integer;
begin
readln(s);
s:=s+' ';
s_new:=''; sl:='';
for i:=1 to length(s) do
 if s[i]<>' ' then sl:=sl+s[i]
 else begin
  while pos(s[i-1],sl)>0 do delete(sl,pos(s[i-1],sl),1);
  s_new:=s_new+sl+s[i-1]+' ';
  sl:='';
 end;
writeln(s_new);
end.

Пример:
нечетное предложение больше четного
нчтное прдложние больше четнго 
info9
#include <iostream>
#include <random>
using namespace std;
typedef size_t _u32;

mt19937 gen { random_device()() };
uniform_int_distribution<> uid(-9, 9);

int main()
{
    const _u32 N = 5;
    int a[N];
    for (_u32 i = 0; i < N; ++i) {
        a[i] = uid(gen);
        cout << a[i] << " ";
    }
    cout << endl;
    // 1 задание
    for (_u32 i = 0; i < N; ++i) {
        if (i != N - 1) swap(a[i], a[i + 1]);
        cout << a[i] << " ";
    }
    cout << endl;
    // 2 задание
    _u32 max = 0, min = INT_MAX;
    for (_u32 i = 0; i < N; ++i) {
        if ((a[i] % 2 == 0) && (a[i] > 0)) {
            if (a[i] > max) max = a[i];
            if (a[i] < min) min = a[i];
        }
    }
    cout << max << endl;
    cout << min << endl;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Можете у кого с информатикой хорошо? Нужно написать две программы на языке Паскаль: 1)Дан одномерный массив целых чисел А[10]. Написать программу, реализующую поиск минимального элемента в массиве, затем организовать замену всех одинаковых минимальных значений на 0. 2)В массиве размерностью N содержатся целые числа, вычислить сумму четных положительных элементов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cutur3414
obitelsvel8
rigina82
msk27
stalker2201
morozov1605
qwe54344
Isaeva_Marin1010
Yevsyukov1697
Moroshkina-Aristova2011
Kelena190533
annazhurawlewa
mixtabak2
Galinagol559
legezin