steff77
?>

ПАСКАЛЬ Составить программу для решения задач: а) заполнить двумерный массив 10х10 целыми случайными числами в интервале (-5;20), вывести данный массив в виде таблицы. б) найти сумму и произведение всех элементов данного массива.

Информатика

Ответы

volkovaoksana19806037

var A: array [1..10,1..10] of integer;

var i,j,s1: integer;

var s2: real;

begin

s1:=0;

s2:=1;

randomize();

For i:= 1 to 10 do

begin

 For j:= 1 to 10 do

 begin

 A[i,j]:=random(24)-4; // Поскольку интервал дан строгий (круглые скобки)

,

// если требовалось включить числа -5 и 20, замените эту строчку на следующую:  A[i,j]:=random(26)-5;

 write(A[i,j]:4);

 s1:=s1+A[i,j];

 s2:=s2*A[i,j];

 end;

 writeln();

end;

writeln('Сумма всех элементов: ',s1);

writeln('Произведение всех элементов: ',s2);

end.

Kuznetsova702

ИМЕНА ПОЛЕЙ И ТИП ДАННЫХ В MS ACCESS

Для определения поля таблицы обязательно задаются Имя поля (Field Name) и Тип данных (Data Type).

Имя поля (Field Name). Каждое поле в таблице должно иметь уникальное имя, удовлетворяющее соглашениям об именах объектов в Access. Оно является комбинацией из букв, цифр, пробелов и специальных символов, за исключением точки (.), восклицательного знака (!), надстрочного знака (`) и квадратных скобок ([ ]). Имя не может начинаться с пробела и содержать управляющие символы с кодами ASCII от 0 до 31. Максимальная длина имени 64 символа.

 

Тип данных в MS Access (Data Type). Тип данных определяется значениями, которые предполагается хранить в поле, и операциями, которые будут выполняться с этими значениями. В Access допускается использование двенадцати типов данных.

Типы данных в MS Access

Рассмотрим вкратце типы данных в MS Access, виды, назначение и допустимый размер  данных, которые могут назначаться полям таблицы в Access.

Текстовый (Text) — используется для хранения текста или комбинаций алфавитно-цифровых знаков, не применяемых в расчетах (например, код товара). Максимальная длина поля 255 знаков.

Поле МЕМО (Memo) — используется для хранения обычного текста или комбинаций алфавитно-цифровых знаков длиной более 255 знаков. Поля с этим типом данных в базах данных формата Access 2007 поддерживают также форматирование текста. Это единственный в Access тип данных, обеспечивающий встроенную поддержку отображения и хранения форматированного текста. Максимальный размер поля 1 Гбайт знаков или 2 Гбайт памяти (2 байта на знак) при программном заполнении полей, и 65 535 знаков при вводе данных вручную в поле и в любой элемент управления, связанный с этим полем.

Числовой (Number) — служит для хранения числовых значений (целых или дробных), предназначенных для вычислений, исключением являются денежные значения, для которых используется тип данных Денежный (Currency). Размер поля 1, 2, 4 и 8 байтов, или 16 байтов (если используется для кода репликации) зависит от типа чисел, вводимых в поле.

Дата/время (Date/Time) — используется для хранения значений даты и времени в виде 8-байтовых чисел двойной точности с плавающей запятой. Целая часть значения, расположенная слева от десятичной запятой, представляет собой дату. Дробная часть, расположенная справа от десятичной запятой, — это время. Хранение значений даты и времени в числовом формате позволяет выполнять различные вычисления с этими данными.

Денежный (Currency) — используется для хранения денежных значений в виде 8-байтовых чисел с точностью до четырех знаков после запятой. Этот тип данных применяется для хранения финансовых данных и в тех случаях, когда значения не должны округляться.

Счетчик (AutoNumber) — используется для уникальных числовых 4-байтовых значений, которые автоматически вводит Access при добавлении записи. Вводимые числа могут последовательно увеличиваться на указанное приращение или выбираться случайно. Обычно используются в первичных ключах.

Логический (Yes/No) — применяется для хранения логических значений, которые могут содержать одно из двух значений: Да/Нет, Истина/Ложь или Вкл/Выкл. (8 битов = 1 байт). Используется 1 для значений Да и 0 для значений Нет. Размер равен 1 биту.

Поле объекта OLE (OLE Object) — используется для хранения изображений, документов, диаграмм и других объектов из приложений MS Office и других программ Windows в виде растровых изображений, которые затем отображаются в элементах управления форм или отчетов, связанных с этим полем таблицы.

Чтобы в Access просматривать эти изображения, необходимо, чтобы на компьютере, использующем базу данных, был зарегистрирован OLE-сервер (про-грамма, поддерживающая этот тип файлов). Если для данного типа файлов OLE-сервер не зарегистрирован, отображается значок поврежденного изображения.

mikhail
Top и Left определяют расстояние от границы поля до верхней и левой границы контейнера, в котором поле находится, соответственно. Name определяет системное имя поля, Color-цвет поля, Text-отображаемый текст на поле, Enabled-возможность взаимодействия с полем(к примеру кликнуть по полю), Visible-видимость поля, Font-шрифт отображаемого текста. Изменить текст в поле можно с метода setText("Строка"). Разместить поле на форме можно с метода add(<компонент>), или с визуального инструмента в Visual Studio, Qt Designer. И самое важное: поле нужно в программе для взаимодействия человека с программой, а так же настройки графического интерфейса. А вот отличие для поля и формы я не знаю((

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ПАСКАЛЬ Составить программу для решения задач: а) заполнить двумерный массив 10х10 целыми случайными числами в интервале (-5;20), вывести данный массив в виде таблицы. б) найти сумму и произведение всех элементов данного массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergeevich-irina
Yuliya mikhail
Евгеньевна_Хусинов
yana2211
stepanova-natalie
sashaleb88
Panda062000
sanyaborisov910067
iracaenko153
coffeenik20233
iptsr4968
vbg238
Fedorov1283
alexander4590
aromastil88