Petrosienko_Larisa,1908
?>

В файле "2.txt" в столбик записаны числа, количество чисел неизвестно. написать программу, которая находит среднее арифметическое D четных элементов файла.

Информатика

Ответы

Спивак

// П

uses Drawman;

begin

Field(3, 4);

ToPoint(1, 1);

PenDown;

OnVector(0, 2);

OnVector(1, 0);

OnVector(0, -2);

end.

// Б

uses Drawman;

begin

Field(3, 4);

ToPoint(1, 1);

PenDown;

OnVector(0, 2);

OnVector(1, 0);

PenUp;

ToPoint(1, 2);

PenDown;

OnVector(1, 0);

OnVector(0, -1);

OnVector(-1, 0);

end.

// Ч

uses Drawman;

begin

Field(3, 4);

ToPoint(1, 3);

PenDown;

OnVector(0, -1);

OnVector(1, 0);

OnVector(0, 1);

OnVector(0, -2);

end.

// Ц

uses Drawman;

begin

Field(25, 27);

ToPoint(5, 25);

PenDown;

OnVector(0, -20);

OnVector(15, 0);

OnVector(0, 20);

OnVector(0, -20);

OnVector(2, 0);

OnVector(0, -3);

end.

// Ш

uses Drawman;

begin

Field(4, 4);

ToPoint(1, 3);

PenDown;

OnVector(0, -2);

OnVector(2, 0);

OnVector(0, 2);

OnVector(0, -2);

Onvector(-1, 0);

OnVector(0,2);

end.

// E

uses drawman;

begin

Field(3, 4);

ToPoint(1, 1);

PenDown;

OnVector(0, 2);

OnVector(1, 0);

PenUp;

ToPoint(1, 2);

PenDown;

OnVector(1, 0);

PenUp;

ToPoint(1, 1);

PenDown;

OnVector(1, 0);

end.

(Если я тебя правильно понял то вот держи)

рад

cheberyako2013

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

var current, past, sum: real;

    i, n: integer;

begin

  current : = 10;

  for i : = 1 to 10 do begin

    writeln(i, ' ', current);

    past : = current;

    current : = current * 1.1;

  end;

  current : = 10; sum : = 0;

  write('n = ');

  read(n);

  for i : = 1 to n do begin

    sum : = sum + current;

    past : = current;

    current : = current * 1.1;

  end;

  writeln('за ', n, ' дней: ', sum);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В файле "2.txt" в столбик записаны числа, количество чисел неизвестно. написать программу, которая находит среднее арифметическое D четных элементов файла.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arturcristian
ruslan
Reutskii884
orion-inginiring7807
pastore
AnzhelikaSlabii1705
stic1995
Любовь
Ни Дмитрий1095
aa276568
akopovarch
lihacheva
ivanovmk1977
websorokin
emilmishin1032