Аверьянова
?>

напишите программу на языке Паскаль. Условие: Напишите программу, которая вводит с клавиатуры три целых числа и вводит их в логическую переменную значения True, если все эти числа двузначные

Информатика

Ответы

evageniy79

program z1;

var a,b,c:integer;

o:boolean;

begin

write ('a = ');

readln (a);

write ('b = ');

readln (b);

write ('c = ');

readln (c);

o:=(a>9) and (a<100) and (b>9) and (b<100) and (c>9) and (c<100);

writeln (o)

end.

VadimovnaIgor
// PascalABC.Net 3.0, сборка 1052
const
  k=5;
  minT=-60;
  maxT=60;
  Umax=4.8;
var
  Ut,s,meanT:real;
  ring:array[1..k] of real;
  i,p:byte;
begin
  { Модерируем работу за 25 с }
  Randomize;
  s:=0;
  { Выход на рабочий режим }
  for i:=1 to k do begin
    Ut:=0.3*Random+3; { колебания напряжения от 3 до 3.3В }
    ring[i]:=minT+(maxT-minT)*Ut/Umax;
    s:=s+ring[i]
  end;
  meanT:=s/k;
  Writeln('t=',k:2,'c, средняя температура= ',meanT:6:2);
  { Рабочий режим }
  for i:=k+1 to 25 do begin
    Ut:=0.3*Random+3; { колебания напряжения от 3 до 3.3В }
    p:=i mod k; if p=0 then p:=k;
    s:=s-ring[p];
    ring[p]:=minT+(maxT-minT)*Ut/Umax;
    s:=s+ring[p];
    meanT:=s/k;
    Writeln('t=',i:2,'c, средняя температура= ',meanT:6:2);
  end
end.
 
Тестовое решение:
t= 5c, средняя температура=  19.61
t= 6c, средняя температура=  20.35
t= 7c, средняя температура=  20.60
t= 8c, средняя температура=  19.68
t= 9c, средняя температура=  20.03
t=10c, средняя температура=  19.17
t=11c, средняя температура=  18.06
t=12c, средняя температура=  17.16
t=13c, средняя температура=  18.15
t=14c, средняя температура=  18.01
t=15c, средняя температура=  18.25
t=16c, средняя температура=  19.44
t=17c, средняя температура=  19.71
t=18c, средняя температура=  18.80
t=19c, средняя температура=  18.54
t=20c, средняя температура=  19.36
t=21c, средняя температура=  19.57
t=22c, средняя температура=  20.20
t=23c, средняя температура=  20.65
t=24c, средняя температура=  20.97
t=25c, средняя температура=  20.46
mashumi2170

"Я самый главный!"- заявил монитор, на мне возникает информация и изображения.

"Нет, я самая главная,- сказала клавиатура, без меня никак, не сможешь ничего оттреадактировать,вбить информацию в память, общаться - да вообще ничего!"

Но память возразила : " Ээх вы, я тут главнее всех, как вы без меня! Ничего не сохранишь, не запомнишь, да в общем без меня очень сложно что-то представить!"

"Да вы что? - начал возмущаться процессор, - Главных не должно быть, мы все представляем собой одно целое!" Так они и воссоединились и представляют собой одну частичку главного . 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

напишите программу на языке Паскаль. Условие: Напишите программу, которая вводит с клавиатуры три целых числа и вводит их в логическую переменную значения True, если все эти числа двузначные
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lzelenyi5
Dmitrievna-Dmitrii980
kuliba
lihacheva
Fedorova_79166180822
klimenokvapeshop1408
Сороченкова-Александр
виталийВячеславович
Баранов955
evge-borisova2
Kelena190533
terma-msk1
anytkaakk
Олегович Паутова
valentinakarma2800