elenalukanova
?>

1. Проанализируйте сходства и отличия инструментов и встроенных обьектов.2. Какие есть модули в SketchUp. позволяющие встроить объекты в программу. 3. Опишите функции модули «Материалы», «Компоненты», «Стили».4.Определите, какие преимущества дают встроенные объекты программ заранее

Информатика

Ответы

Sergeevna803

# подключаем модуль, чтобы использовать случайные числа

from random import *

 

a = [0]*32   # Создание списка

for i in range (0, 32):

   a[i] = randint(1, 101)  # заполнение случайными числами

   

a.sort() # сортировка

print(a) # вывод на экран

b = int(input('Введите число для поиска : '))   # ввод числа для поиска

 

mid = len(a) // 2  # определяем средний элемент списка

low = 0            # определяем верхнюю границу списка

high = len(a) - 1  # определяем верхнюю границу списка

step = 0           # обнуляем счётчик шагов

 

while a[mid] != b and low <= high:  # в цикле пока не нашли искомый элемент

   if b > a[mid]:  # если искомый элемент > среднего элемента в диапазоне

       low = mid + 1  # то нижнюю границу выставим в середину диапазона

   else:           # если искомый элемент <= среднего элемента в диапазоне

       high = mid - 1 # то верхнюю границу выставим в середину диапазона

   mid = (low + high) // 2  # считаем новый средний элемент диапазона

   step += 1  # увеличиваем счётчик на 1

 

if low > high:

   print('Нет числа')

else:

   print('Количество шагов = ', step)

   print('Индекс = ', mid)

razumeiko0790

Объяснение:

использовать Чертежник

алг

нач

поднять перо

сместиться в точку (2,2)

опустить перо

сместиться на вектор (0,3)

сместиться на вектор (3,-3)

сместиться на вектор (-3,0)

поднять перо

сместиться в точку (5,2)

опустить перо

сместиться на вектор (1,1)

сместиться на вектор (-3,3)

сместиться на вектор (-1,-1)

поднять перо

сместиться в точку (3,6)

опустить перо

сместиться на вектор (4,6)

поднять перо

сместиться в точку (4,5)

опустить перо

сместиться на вектор (5,5)

поднять перо

сместиться в точку (5,4)

опустить перо

сместиться на вектор (6,4)

поднять перо

сместиться в точку (6,3)

опустить перо

сместиться на вектор (7,3)

кон


написать программу для построения изображения. среда программирования кумир. исполнитель чертежник.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Проанализируйте сходства и отличия инструментов и встроенных обьектов.2. Какие есть модули в SketchUp. позволяющие встроить объекты в программу. 3. Опишите функции модули «Материалы», «Компоненты», «Стили».4.Определите, какие преимущества дают встроенные объекты программ заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

elenak26038778
svetrusval
Александра Викторович531
oyudina
appbiznessm
Назаров588
dkedrin74038
Спиридонова
arturusinsk5
Aleksandrovich_Mitoyan1138
Gesper63
kruttorg
shumilovs7252
zbellatriks
zatoichi69