Pogosyan Nataliya
?>

Написать программу, используя линейную структуру. С клавиатуры вводится любое целое число. Написать программу, которая вычисляет его квадрат.​

Информатика

Ответы

urazmetova

program noname;
uses crt;
var
a:array[1..1000,1..1000] of integer;
i,j,min,n,m,l:integer;
begin
clrscr;
write('n='); readln(n);
write('m='); readln(m);
for i:=1 to n do
for j:=1 to m do begin
write('a[',i,',',j,']=');
readln(a[i,j]);
end;
for i:=1 to n do begin writeln;
for j:=1 to m do
write(a[i,j],' ');
end;
writeln;

for i:=1 to n do begin
min:=0;
for j:=1 to m do
if min>a[i,j] then begin min:=a[i,j]; l:=j; end;
if min<>0 then
writeln ('v ',i,' stroke indexy poslednego otricatelnogo chisla = ',i,',',l)
else writeln ('v ',i,' stroke otricatelnyh chisel net');
end;
readkey;
end.

muz-cd

На входе вводим с клавиатуры размерность массива: n строк и m столбцов.

Первые два вложенных цикла - это ввод двумерного массива с датчика случайных чисел randomize.

Далее во вложенных циклах ищем максимальную сумму элементов по строкам и запоминаем номер строки в переменную k.

Строку с выводом s и k писать не нужно.

Далее один цикл обмена к-той строки и последней.

Последние вложенные циклы выводят изменённый массив.

Прежде чем выводить массив нужно поставить поверку:

If k=m then write(‘Менять строки местами не нужно’) else begin и последние два вложенных цикла.


Написать программу на ! дана прямоугольная матрица размером . определить номер строки, сумма элемент

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, используя линейную структуру. С клавиатуры вводится любое целое число. Написать программу, которая вычисляет его квадрат.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Grishanin
zbellatriks
Спиридонова
elenak26038778
Galinagol559
MariyaKhanbalaeva585
Александрович Владимирович
aeykin
oalexandrova75
edvard-b
Максим_Нина
Андреевич-Екатерина1974
Serkova_Elena251
Оксана170
Aleksandrovich_Mitoyan1138