nkochladze
?>

Задача: Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра. Там нету команд такие по англ, только есть русские такие как: алг, вещ, нс, ввод, вывод, кон, всё, и т.д На языке кумир только, то что вы кидаете команды по англ у нас того нету ещё тольок на русском какие я уже перечислил, Вот прек. программу Кумир. Зарание если звёзд и сердечко <З

Информатика

Ответы

bereza81
2
а)
INPUT "Ширина первого прямоугольника";A1
INPUT "Длина первого прямоугольника";B1
INPUT "Ширина второго прямоугольника";A2
INPUT "Длина второго прямоугольника";B2
IF A1/A2=B1/B2 THEN PRINT "Фигуры подобны" ELSE PRINT "Нет подобия"

б)
PRINT '"Первый треугольник:"
INPUT "Первая сторона";A1
INPUT "Вторая сторона";B1
INPUT "Третья сторона";C1
PRINT '"Второй треугольник:"
INPUT "Первая сторона";A2
INPUT "Вторая сторона";B2
INPUT "Третья сторона";C2
IF (A1/A2=B1/B2) AND (B1/B2=C1/C2) THEN PRINT "Фигуры подобны" ELSE PRINT "Нет подобия"
vardartem876
Uses  crt;const  nmax=100;var  a1,a2: array[1..nmax] of integer;  n,i,b,k,s: integer;begin  randomize;  clrscr;  repeat    write('Введите размер массива n (n in [1..',nmax,']): ');    readln(n);    write('Введите число B (0<B<100): ');    readln(b);  until (n in [1..nmax]) and (b in [1..99]);  writeln('Массив A1');  for i:=1 to n do  begin    a1[i]:=random(99);    write(a1[i]:4);    if a1[i]>b then    begin      inc(k);      a2[k]:=i;      s:=s+a1[i];    end;  end;  writeln;  writeln('Среднее элеметов, больших B = ',s/k:0:2);  writeln('Массив A2:');  for i:=1 to k do write(a2[i]:4);  readln;end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача: Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра. Там нету команд такие по англ, только есть русские такие как: алг, вещ, нс, ввод, вывод, кон, всё, и т.д На языке кумир только, то что вы кидаете команды по англ у нас того нету ещё тольок на русском какие я уже перечислил, Вот прек. программу Кумир. Зарание если звёзд и сердечко <З
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Семеновна-Павел
борисовна Елена78
keykov35
ddavydov1116
Morozova-Starikov
Терентьева
Gennadevich Aleksandr
varvara82193
bmargarita
kon200182
diannaevaaa
Vyacheslavovich1431
Александр Елена1290
Дан логотип. Выбери ответ.
d43irina
groomingprofi56