Gennadevich Aleksandr
?>

по информатике надо. Надо решить на языке КуМир задачу: Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра. Только на языке кумир. Заранее тебе огромное, или вам. :) Там в программе ещё есть команды: алг, нач, ещё, вывод, ввод, и, нс и тд. если дам 5 звёзд и

Информатика

Ответы

ИП-Сысоев1628

var

a,b:longint;

begin

readln(a,b);

while a>0 do

begin

if a mod 10=b then

begin

writeln('Est');

halt;

end;

a:=a div 10;

end;

writeln('Net');

end.

informalla
Var
 A:array[1..4] of integer;
 i,j,R,P:integer;
function HOD(c,b:integer):integer;
 begin
  while c<>b do
   if c>b
     then
      c:=c-b
    else
     b:=b-c;
  HOD:=c;
 end;
function HOK(c,b, RR:integer):integer;
 begin
  if ((c mod b=0) or (b mod c=0)) and ((c div b > 1) or (b div c > 1))
   then
     begin
       if c>b
          then
           HoK:=c
         else
          HOK:=b;
     end
    else
     HOK:=(c*b) div RR;
 end;
begin
 A[1]:=36;
 A[2]:=54;
 A[3]:=18;
 A[4]:=15;
 P:=1;
 R:=HOD(A[1],A[2]);
 P:=HOK(A[1], A[2], R);
 for i:=3 to 4 do
  begin
   R:=HOD(R, A[i]);
   P:=HOK(P, A[i],R);
  end; writeln('HOK = ',P);
end.
mkrtchyananaida6995
Var
 A:array[1..4] of integer;
 i,j,R,P:integer;
function HOD(c,b:integer):integer;
 begin
  while c<>b do
   if c>b
     then
      c:=c-b
    else
     b:=b-c;
  HOD:=c;
 end;
function HOK(c,b, RR:integer):integer;
 begin
  if ((c mod b=0) or (b mod c=0)) and ((c div b > 1) or (b div c > 1))
   then
     begin
       if c>b
          then
           HoK:=c
         else
          HOK:=b;
     end
    else
     HOK:=(c*b) div RR;
 end;
begin
 A[1]:=36;
 A[2]:=54;
 A[3]:=18;
 A[4]:=15;
 P:=1;
 R:=HOD(A[1],A[2]);
 P:=HOK(A[1], A[2], R);
 for i:=3 to 4 do
  begin
   R:=HOD(R, A[i]);
   P:=HOK(P, A[i],R);
  end; writeln('HOK = ',P);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

по информатике надо. Надо решить на языке КуМир задачу: Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра. Только на языке кумир. Заранее тебе огромное, или вам. :) Там в программе ещё есть команды: алг, нач, ещё, вывод, ввод, и, нс и тд. если дам 5 звёзд и
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dmitrievich1871
Александра-Андрей909
ilysozkn27
Vyacheslavovich1431
Khrimyan1207
Воздвиженская
groomingprofi56
Andrei_Mariya
bellatrixstudio
rosik76
OlgaVasilevna
d43irina
nkochladze
diannaevaaa
olgusikok