Надежда-Алексеевна82
?>

ОЧЕНЬ Программа С++. Составить программу калькулятор, которая умеет выполнять два действия-сложение и вычитание с двумя числами. Пользователь вводит два числа, программа выполняет два действия и выводит результат. Задание необходимо выполнить с использованием функции.ОТВЕТЬТЕ

Информатика

Ответы

natalia-bokareva

#include <iostream>

using namespace std;

double sum_raz(double a, double b) {

   cout << "Сумма " << a+b << endl;

   cout << "Разность " << a-b;

}

int main() {

   double a, b;

   cin >> a >> b;

   sum_raz(a, b);

   return 0;

}

kep92

var

A: array [1..100, 1..100] of integer;

i, j, n, y, mini, minj, maxi, maxj, temp: integer;

const

format = 4;

begin

Randomize;

writeln('Введите колличество строк и столбцов через пробел (пример: 3 4)');

read(n, y);

writeln('Исходный массив');

for i := 1 to n do

begin

for j := 1 to y do

begin

A[i, j] := random(40) - 20;

write(A[i, j] : format);

end;

writeln;

end;

mini := 1;

minj := 1;

maxi := 1;

maxj := 1;

for i := 1 to n do

for j := 1 to y do

begin

if A[i, j] < A[mini, minj] then

begin

mini := i;

minj := j;

end ;

if A[i, j] > A[maxi, maxj] then

begin

maxi := i;

maxj := j;

end ;

end;

writeln;

WriteLn('Минимальный = ', A[mini, minj], ' в ', mini, ' строке ', minj, ' колоне.');

WriteLn('Максимальный = ', A[maxi, maxj], ' в ', maxi, ' строке ', maxj, ' колоне.');

temp := A[maxi, maxj];

A[maxi, maxj] := A[mini, minj];

A[mini, minj] := temp;

writeln;

writeln('Преобразованный массив');

for i := 1 to n do

begin

for j := 1 to y do

write(A[i, j] : format);

writeln;

end;

readln;

end.


Нужна ваша Сформировать в паскале двумерный массив приоизвольного размера (размер массива вводить с
pri02

Объяснение:

A       B   С      B∧A       A→B∧A     A→B∧A→C          A→B∧A→C→C

0     0      0       0               1            0                                     1

0     0      1        0               1            1                                      1

0     1       0       0               1            0                                     1

0     1       1        0               1            1                                      1

1     0       0       0               0           1                                     0

1     0       1        0               0           1                                     1

1     1        0       1                1            0                                    1

1     1        1        1                 1           1                                     1

Упрощение:

(A→B∧A→C)→C = ((¬A∨B)→C)→C = (C∨A¬B)→C=¬ A∨C∨ B

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ОЧЕНЬ Программа С++. Составить программу калькулятор, которая умеет выполнять два действия-сложение и вычитание с двумя числами. Пользователь вводит два числа, программа выполняет два действия и выводит результат. Задание необходимо выполнить с использованием функции.ОТВЕТЬТЕ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мусаев Игоревич371
bas7572513
wwladik2606222
akudryashov
elenaneretina
хаджимурод1172
Matveevanastya0170
Александрович
swetlanafatinia7323
SlavaA99
sabinina0578
mg4954531175
федороа
KrisTinka
druzhbamagazin2457