cimora-kativ
?>

Кто разбирается хорошо в информатике Определите значения переменной x после выполнения фрагмента программы: a:=2; x:=a+2; if x>4 then x:=x+2*a else x:=a-x;

Информатика

Ответы

daarisgoy

Объяснение:

изначально  x=0, т.к к нему не присвоено значение. Затем мы прибавляем к а 2, получается x=4, затем по условия х=4, значит не проходит, следовательно х=а-х=2-4=-2

zharovaleks
Const
  n = 20;

var
  x: array[1..n] of integer;
  i, s: integer;

begin
  Randomize;
  s := 0;
  Write('Элементы массива: ');
  for i := 1 to n do
  begin
    x[i] := Random(101) - 50;
    Write(x[i]:5);
    if x[i] >= 0 then s := s + sqr(x[i])
  end;
  Writeln(#13#10, 'Сумма квадратов неотрицательных элементов равна ', s)
end.

Тестовое решение:
Элементы массива:   -29    1  -36   50  -29   31    4   28  -25   -1   17  -45  -48  -19  -49  -49  -30  -22    8   18
Сумма квадратов неотрицательных элементов равна 4939
sveta1864
Сначала спрашивайте у пользователя число n, потом заполняйте массив (с проверкой на [-100..100]), потом в цикле проверяйте каждый элемент массива на кратность 5. Параллельно с проверкой на кратность (в том же цикле) кидайте первое кратное число в переменную max, и сравнивайте с это переменной другие числа, кратные 5. Если больше - перезаписываете значение max

Цикл: (counter - счетчик, n - колво чисел в массиве)

max := 0;
for counter = 1 To n Do
if (Massive[counter] mod 5) = 0 then
        if Massive[counter] > max then max := Massive[counter];

В конце выводите max

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кто разбирается хорошо в информатике Определите значения переменной x после выполнения фрагмента программы: a:=2; x:=a+2; if x>4 then x:=x+2*a else x:=a-x;
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

artem-whitenoise142
Александрович686
kulinarprotv
krasilnikov74
Ерохин
autofilters27
vedaikin
Глазкова633
ktripoleva294
annatarabaeva863
Semenova1719
sv-rud
Zaikinarusina
raa-0485428
Ladyby6224