Dmitrievna Lvovich
?>

Требовалось написать программу, которая определяет, лежит ли точка А(х, у) внутри некоторого кольца («внутри» понимается в строгом смысле, т.е. случай, когда точка А лежит на границе кольца, недопустим Центр кольца находится в начале координат. Для кольца заданы внутренний и внешний радиусы r1, r2; известно, что r1 отлично от r2, но неизвестно, r1 > r2 или r2 > r1. В том случае, когда точка А лежит внутри кольца, программа должна выводить соответствующее сообщение, в противном случае никакой выходной информации не выдается. Программист сделал в программе ошибки. var x, у, rl, r2:real; h: real;beginreadln (x, у, rl, r2);h := sqrt (x*x + y*y);if (h < rl) AND (h > r2) then writeln ('точка А лежит внутри кольца');end.Последовательно выполните задания:1. Приведите пример таких чисел х и у, при которых программа неверно решает поставленную задачу.2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими поэтому можно указать любой доработки исходной программы).3. Укажите, как можно доработать программу, чтобы она не содержала логических операций AND или OR.Примечание: для обозначения расстояния от точки А до начала координат используется вс переменная h.​

Информатика

Ответы

aromastil88
Var        
R1, R2, R3, S1, S2, S3: Integer;        
begin             
writeln('Введите размеры рации и чемодана');             
readln(R1, R2, R3, S1, S2, S3);             
 if ((R1 < S1) and (R2 < S2) and (R3 < S3)) or             
((R3 < S3) and (R2 < S1) and (R1 < S2)) or             
((R1 < S1) and (R2 < S3) and (R3 < S3)) or             
((R2 < S2) and (R1 < S3) and (R3 < S1)) or             
 ((R2 < S1) and (R3 < S2) and (R1 < S3)) or             
((R1 < S2) and (R3 < S1) and (R2 < S3)) then
WriteLn('ПОМЕЩАЕТСЯ')  
 else
WriteLn('НЕ ПОМЕЩАЕТСЯ');
end.
Дементьева-Артем1315
Задача 7. ВОДОЛАЗКА
Задача 2. после 6 применений 64 четных цифры (после каждого применения их количество увеличивается в 2 раза)
Задача 1. не может быть Даша второй, т.к. это утверждение в 4 и 5 строках. Не может быть третьей Ира (предполагается в 3 и 5 строках). Значит первая Маша. А Даша и Ира - не призеры. Из 4-й строки получаем. что и Боря не призер. Из 1 и 3 строки получаем, что Вася - не призер (т.к. указано что Вася второй и Вася третий). Значит призер Таня (не первая и не третья, значит - вторая). Из 2 строки получаем, что и Гена не призер. Остается Антон - третий
ответ: Маша, Таня, Антон
Задача 3. Всего можно составить  60 трехзначных чисел. Числе. меньших 200, 12. Вероятность 12/60=0,2
Задача 9. 16
Задача 4. Можно (Земля-Марс-юпитер-Венера-Меркурий)
Задача 6.
370
343
640
613
910
901
271
253
550
 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Требовалось написать программу, которая определяет, лежит ли точка А(х, у) внутри некоторого кольца («внутри» понимается в строгом смысле, т.е. случай, когда точка А лежит на границе кольца, недопустим Центр кольца находится в начале координат. Для кольца заданы внутренний и внешний радиусы r1, r2; известно, что r1 отлично от r2, но неизвестно, r1 > r2 или r2 > r1. В том случае, когда точка А лежит внутри кольца, программа должна выводить соответствующее сообщение, в противном случае никакой выходной информации не выдается. Программист сделал в программе ошибки. var x, у, rl, r2:real; h: real;beginreadln (x, у, rl, r2);h := sqrt (x*x + y*y);if (h < rl) AND (h > r2) then writeln ('точка А лежит внутри кольца');end.Последовательно выполните задания:1. Приведите пример таких чисел х и у, при которых программа неверно решает поставленную задачу.2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими поэтому можно указать любой доработки исходной программы).3. Укажите, как можно доработать программу, чтобы она не содержала логических операций AND или OR.Примечание: для обозначения расстояния от точки А до начала координат используется вс переменная h.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Valerevna Tuzova
nikitavertiev98400
Korikm
viktorovna_Imamaevich679
yulyaderesh
len22
ktripoleva294
sanina611
lele52
lyubavalev8
ekaterinava90
Болеславовна
aureole6452
Aleksandr_Vasilev
andrey4work918
▲