spodobnyi
?>

Решить 1 и 3 задачу Язык паскаль

Информатика

Ответы

oksanashabanovadc3197

112222

Объяснение:

Скорее всего, условие задачи сформулировано некорректно, ибо составить программу, содержащую не более пяти команд не получится, и сейчас объясню почему.

Так как нужно из числа 4 получить число 80, то первая команда не может являться "2", в противном случае мы уйдем в отрицательные числа. Тогда первая команда - "1", и теперь нам нужно из числа 20 получить число 80. Рассмотрим несколько случаев, когда последней командой мы получаем число 80.

1 случай.

Если последняя команда - "1", то это возможно, когда предпоследний результат будет равен 16, однако так как наша траектория точно содержит число 20, которое кратно 5, то, применяя далее наши команды, мы всегда будем получать число, кратное 5, а нам нужно получить 16. Противоречие.

2 случай.

Теперь рассмотрим ситуацию, когда последняя команда - "2". То есть предпоследний результат равен 85. Если получать число 85 командой "1", то траектория должна содержать число 17. Из соображений  кратности (см. 1 случай) это невозможно. Значит вторая с конца команда должна являться "2". Аналогично рассуждая, приходим к выводу о том, что и третья, и четвертая команды с конца тоже должны быть "2". То есть наша траектория имеет вид 1*2222, причем на месте "*" должна быть такая траектория команд, которая позволит получить из числа 20 число 100. Ясно, что наименьшая траектория будет 112222, но она содержит 6 команд. Противоречие.

Получается, что из числа 4 получить число 80 программой, которая бы содержала не более 5 команд, действительно не получится. Но если говорить о наименьшей траектории, то 112222 - будет являться ответом на эту задачу.

chermen40

Первая задача.

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   

   int Q;

   cin >> Q;

   if (Q >= 100 && Q <= 999)

   {

       cout << "это 3-хзначное число";

   }

   else

   {

       cout << "это не 3-хзначное число";

   }

   cout << endl;

   return 0;

};

Вторая задача.

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   

   int D;

   cin >> D;

   if (D >= 10 && D <= 20)

   {

       cout << "Принадлежит";

   }

   else

   {

       cout << "Не принадлежит";

   }

   

   cout << endl;

   return 0;

};

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить 1 и 3 задачу Язык паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kurlasku
mary---jane49
tatianaesipenko
olechka197835
matveevaev81
Спиридонова
Грачева мураховская
ЕВгений_денис643
vak1984
vsemvsego306
abahtina582
borzhemskaya19823110
delena6467
pronikov90
proh-dorohova5244