Baidina
?>

Элементы массива ан вводятся с клавиатуры. Определите количество элементов, равных 3

Информатика

Ответы

ti2107

К какому виду компьютерной графики относится графика с представлением изображения в виде совокупностей точек?

- Графика с представлением изображения в виде совокупностей точек относится к растровой графики.

Что собой представляет компьютерная графика?

- Компьютерная графика представляет собой вид деятельности, в которой компьютерную технику используют для получения, редактирования, хранения и визуализации информации, получаемой из внешнего мира, в виде цифровой информации.

Перечислите графические примитивы. Для чего каждый из них используется?

- Примитивы  можно классифицировать:  односложные  и составные;

плоские  и объемные (3d).

annanas08

Функция strlen() возвращает длину строки, то есть strlen(str) - длина строки str. В массиве выделено место для 101 символа, так как по условию максимальная длина введенной строки - 100 символов, но еще одно место в массиве нужно для нуль-терминатора(\0), иначе программа не сможет успешно работать со строкой и для некоторых входных данных будет выдаваться ошибка. Так как str - массив символов типа char, то можно обращаться к каждому элементу массива с индекса, что и происходит в цикле for.

Объяснение:

#include <iostream>

using namespace std;

int main()

{

char str[101];

cin >> str;

for (int i = 0; i < strlen(str); i++) {

 cout << str[i];

 if (i != strlen(str)-1) cout << '*';

}

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Элементы массива ан вводятся с клавиатуры. Определите количество элементов, равных 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Goldaram84
igor51766771
mel9152480522
Динков
pucha5261
Роман Александр66
Сергей
btatarintsev
Yurevich1701
Александр Сергей
mariyachervonnaya44
bieku68
nv6634
mokeevahelena
azarov8906