alina Korneev
?>

Написать программу, которая вводит массив из N вещественных чисел, а затем меняет местами наибольший и наименьший элементы массива. Протестировать программу на трѐх произвольных тестах

Информатика

Ответы

lazu8375

Зависит от языка программирования. Тебе какой нужен?

agaloan8

var

 a: string;

 b: array[1..9]of integer;

 sort: boolean;

 max, k: integer;

begin

 Readln(a);

 for var i := 1 to Length(a) do

   b[i] := strtoint(a[i]);

 sort := false;

 while sort = false do

 begin

   sort := true;

   k += 1;

   for var i := 1 to Length(a)-1 do

   begin

     if a[i] < a[i+1] then

     begin

       sort := false;

       var value2 := a[i];

       a[i] := a[i+1];

       a[i+1] := value2;

     end;

   end;

 end;

 write(a[1]);

end.

Программа написана на PascalABC.net

на free pascal или turbo pascal она может не работать

Andreevich440


1. в случаях, когда надо выполнить не следующий по порядку оператор, а какой-нибудь другой, отмеченный меткой (например выйти из цикла)
4. "следование", "ветвление", "цикл с предусловием"
5.  для осуществления на него безусловного перехода;
6. для вывода графики
7. для очистки экрана
8. операторы присваивания, безусловный оператор, оператор вызова процедуры, пустой оператор
9. power(x,y)
10. integer
11. :=
12. F9
13. write и writeln
14. Раздел описаний
16.  операторы, не содержащие никаких других операторов    
17. операторы присваивания, безусловный оператор, оператор вызова процедуры, пустой оператор
18. for; while.. do; repeat...until
19. текстовые файлы; типизированные файлы; нетипизированные файлы
опрераторов if и case of
29.  writeln без параметров
30.  :
31.  закрашивает замкнутую область, используя текущие стиль и цвет закраски.
32.  вывод на экран прямоугольников
33.  Объяснения програмиста.
34.  Никаких действий не выполняет, нужен для осуществления на него безусловного перехода
35.  покомандный анализ, обработку и выполнение исходной программы
36.  Никлаус Вирт в 1968—1969
37.  весь блок, в котором объявлена данная метка, за исключением внутренних блоков
38.  Отметьте, из каких элементов состоит алгоритмический язык?
39.  Program
40.  Var
41.  Set of
42. Шесть: следование; ветвление; цикл с предусловием; цикл с постусловием; цикл с параметром; вариант.
43.  Укажите приоритет операций в языке Паскаль.
44.  26 латинских строчных и прописных букв; знак подчеркивание; 10 цифр; знаки операций; ограничители; спецификаторы; служебные слова; пробел.
45.  26 латинских строчных и прописных букв; знак подчеркивание; 10 цифр; знаки операций; ограничители; спецификаторы; служебные слова; пробел.
47.   предложение языка программирования, задающее полное описание некоторого действия, которое может выполнить компьютер
48.   данные, необходимые для выполнения оператора
49.  begin ... end
50.  S - начиная с позиции курсора, выводится значение S (строка или массив символов)
51.  имя метки и двоеточие после него
52.  компилятор - это программа-переводчик, читает всю программу целиком, делает ее перевод и создает законченный вариант программы на машинном языке, который затем и выполняется

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вводит массив из N вещественных чисел, а затем меняет местами наибольший и наименьший элементы массива. Протестировать программу на трѐх произвольных тестах
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

m79857860146895
violetta152028
argent
skzzkt
vsemvsego306
masamosijcuk140244
Gradus469
Dmitriy793
S.V. Zhoraevna1677
saytru5850
titancore
olimov9
kartyshkinaaa
stairov536
ilma20168