olgakuz00261
?>

Дано натуральные числа n и k. Вычислить сумму k старших разрядов (находящихся слева) цифр числа. Написать программу в C++, используя циклы while или for.

Информатика

Ответы

vvb1383

#include <iostream>

int main()

{

int n,n1,k,k1;

std::cout << "n = ";

std::cin >> n;

std::cout << "k = ";

std::cin >> k;

n1 = n;

k1 = 1;

while ((n1 /= 10) > 0) k1++;

n1 = n;

while (k1-- != k) n1 /= 10;

k1 = n1%10;

while ((n1 /= 10) > 0) k1 += n1 % 10;

std::cout << "Result = " << k1;

   return 0;

}

vgolentsova

Увы, нет.

...var Y:array[1..N] of real... ошибка в написании, компилятор сообщит, что тип параметра не может быть описанием массива с границами. Пример:

var a:array [1..n] of real;                                                                                  Procedure ab(var b:array [1..n] of real);

К сожалению переменная и формальный параметр не одного типа.

Стоит использовать Type:

type ba= array [1..n] of real;                                                                                  var a: ba;                                                                                                   Procedure ab(var b:ba);

r682dm2011

t ≈ 17c

Объяснение:

Ну, первым делом нам надо перевести 259 килобайт в биты, мы знаем, что в одном килобайте 1024 байта, а в одном байте 8 бит, то есть:

259 * 1024 * 8 = 2121728 бит

Это мы узнали объём сообщения в битах, теперь найдем время, которое понадобится для передачи этого сообщения с модема, с пропускной в 128000 бит/с. "Бит/с" нам показывает, сколько бит информации может передать этот модем за 1 секудну, ну это логично, теперь чтобы найти время, нам надо объём сообщения поделить на пропускную модема:

t = 2121728 бит / 128000 бит/с ≈ 16,6с

Ах, да, надо дать ответ целым числом, тогда t ≈ 17c

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральные числа n и k. Вычислить сумму k старших разрядов (находящихся слева) цифр числа. Написать программу в C++, используя циклы while или for.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aamer9992680
ananyananar
avolodyaev
klodialeit36
Donat-Evgeniya793
Екатерина_Кирушев
Ни Дмитрий1095
cristiansirbu9974
praskovya17
yelenaSmiryagin
ИП-Сысоев1628
Wunkamnevniki13438
joini09
Vladimirovich58
mgg64