airlineskozlova69
?>

С клавиатуры вводится число N, и далее N чисел. Составить программу записывающую в файл только четные числа из тех чисел которые вводит пользователь​

Информатика

Ответы

ipKAV85
1.Если СПТ умеет автоматически строить оглавление документа, да ещё размещать
его как в конце, так и в начале по желанию пользователя, то это уже не форматер. А если СПТ позволяет подготовить на экране или включить в документ рисунок, выполненной другой программой, то независимо от плюсов и минусов в других графах перечня операций это — настольное издательство.

Такая классификация удобна пользователю-покупателю. Но и она не отражает сути вопроса, так как разработчики сложных систем, особенно в процессе развития удачных версий, стремятся привлечь покупателя «экзотическими» возможностями. При этом система, как будет показано ниже, не переходит в другой класс, но уловить это по перечню операций крайне трудно.

Итак, единого классификационного признака нам пока обнаружить не удалось. Но может быть этого и не нужно пользователю, к тому же только начинающему работать и жаждущему скорее приступить к делу, чем выслушивать «парламентские прения»? Говорят, «скупой (в данном случае — на время чтения) платит дважды», а конструктивная классификация имеет не абстрактный смысл, но позволяет оценить предполагаемую покупку не только по красоте упаковки…

Сначала, не заботясь о различиях других классов систем подготовки текстов, попробуем «отсечь» форматеры. В словаре [7] можно найти следующие определения:

V«Форматер (formatter)1 — программа или часть системы подготовки текстов, выполняющая форматирование. См. тж. text formatting.»…

«Text formatting (форматирование текста) — в системах подготовки текстов — преобразование текста в вид, в котором он должен печататься: формирование абзацев, центрирование заголовков, выравнивание полей, разбиение на страницы.»
2.это текст, кликая на который ты переходишь на какой-либо другой ресурс интернета (и не только интернета). Гипертекст часто еще применяют в таких программах как Word и Exel.
kirillprotopopov1
// PascalABC.NET 3.0, сборка 1076
type
  Point=record
  x,y:real
  end;
  Line=record
  A,B:Point
  end;
  Triangle=record
  A,B,C:Point;
  sa,sb,sc:real; { длины сторон }
  end;

procedure GetPoint(PointName:char; var M:Point);
begin
  Write('Введите координаты точки ',PointName,'(x,y): ');
  Read(M.x,M.y)
end;

function LineLength(A,B:Point):real;
begin
  LineLength:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;
 
procedure CreateTriangle(var T:Triangle; var l:boolean);
begin
  With T do begin
    GetPoint('A',A);
    GetPoint('B',B);
    GetPoint('C',C);
    sa:=LineLength(B,C);
    sb:=LineLength(A,C);
    sc:=LineLength(A,B);
    l:=(sa+sb>sc) and (sa+sc>sb) and (sb+sc>sa)
  end
end;

function TriangleIsLikes(T1,T2:Triangle):boolean;
var
  k1,k2,k3:real;
begin
  k1:=T1.sa/T2.sa; k2:=T1.sb/T2.sb;
  if k1=k2 then begin
    k3:=T1.sc/T2.sc;
    TriangleIsLikes:=k1=k3
    end
  else
    TriangleIsLikes:=False
end;

var
  T1,T2:Triangle;
  legal:boolean;
begin
  Writeln('*** Первый треугольник ***');
  CreateTriangle(T1,legal);
  if legal then begin
    Writeln('*** Второй треугольник ***');
    CreateTriangle(T2,legal);
    if legal then
      if TriangleIsLikes(T1,T2) then Writeln('Треугольники подобны')
      else Writeln('Треугольники не подобны')
    else Writeln('Треугольник невозможно построить')
    end
  else Writeln('Треугольник невозможно построить')
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С клавиатуры вводится число N, и далее N чисел. Составить программу записывающую в файл только четные числа из тех чисел которые вводит пользователь​
Ваше имя (никнейм)*
Email*
Комментарий*