vvb1383
?>

Напишите программу, которая определяет существует ли треугольник из введённых трех значений сторон. На трех строках вводятся значения сторон треугольника. Программа должна вычислять можно ли построить треугольник из введенных длин сторон треугольника. Если треугольник существует, то программа выводит сообщение "Exist". Если нет, то программа выводит сообщение "Not exist".​

Информатика

Ответы

gbg231940
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=20;
  var a:=ArrRandom(k,-50,50); a.Println;
  var n:=ReadInteger('Введите число циклических сдвигов влево:') mod k;
  if n>0 then a:=(a[n:]+a[:n]).ToArray;
  a.Println
end.

Примеры
-31 -27 -45 21 -49 14 -40 21 -13 -45 6 -44 -17 -12 9 4 25 -22 -11 35
Введите число циклических сдвигов влево: 5
14 -40 21 -13 -45 6 -44 -17 -12 9 4 25 -22 -11 35 -31 -27 -45 21 -49

-22 14 25 3 -12 -46 -12 -32 -12 -23 8 -44 -8 42 16 9 -8 33 -22 43
Введите число циклических сдвигов влево: 0
-22 14 25 3 -12 -46 -12 -32 -12 -23 8 -44 -8 42 16 9 -8 33 -22 43

-18 -42 10 48 -41 -32 -29 19 39 49 44 -1 15 -19 -32 -35 36 -6 -38 38
Введите число циклических сдвигов влево: 21
-42 10 48 -41 -32 -29 19 39 49 44 -1 15 -19 -32 -35 36 -6 -38 38 -18

-36 42 29 0 -43 -33 -17 46 -34 7 -6 -20 -30 19 -30 36 43 -22 -44 -44
Введите число циклических сдвигов влево: -1
-36 42 29 0 -43 -33 -17 46 -34 7 -6 -20 -30 19 -30 36 43 -22 -44 -44
Ни Дмитрий1095
PROGRAM B05;
VAR
    a,b:integer;

BEGIN
  writeln('a). Введите два целых числа');
  write('Первое число: '); readln(a);
  write('Второе число: '); readln(b);
 
  if (a=b) then
    writeln('Числа равны.')
  else if (a<b) then
    writeln('Наименьшее число = ', a)
  else
    writeln('Наименьшее число = ', b);
  writeln('');

  write('б). Введите число: '); readln(a);
  if (a>0) then begin
    b:=a-30;
    writeln('Число неотрицательное. ', a,'-30=',b);
  end else if (a<0) then begin
    b:=a+70;
    writeln('Число отрицательное. ', a,'+70=',b);
  end else
    writeln('Число равно 0');
  writeln('');
 
  write('с). Введите целое число: '); readln(a);
  if odd(a) then
    writeln('Число ', a,' нечетное')
  else
    writeln('Число ', a,' четное');

END.

Даны 2 целых числа найти наименьшее из них. вести число, если не отриц. вычислить 30 прибавить к нем

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая определяет существует ли треугольник из введённых трех значений сторон. На трех строках вводятся значения сторон треугольника. Программа должна вычислять можно ли построить треугольник из введенных длин сторон треугольника. Если треугольник существует, то программа выводит сообщение "Exist". Если нет, то программа выводит сообщение "Not exist".​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Игорь Андрей
sargisyan
Lorvi_Shevkunova849
Vasilevna_Shabanova1502
ielienakozlova696
alena
Anatolevich1506
svetasvetlana429
pk199888
arturo95
Svetlana1287
МуратМарина1140
fakyou170
ninakucherowa
zoomagazinkotmatroskin