ilysozkn27
?>

Напишите программу, которая требует ввести целое число. Проверяет, положительное оно или нет. Если число положительное, - увеличивает его на 200, если нет, -уменьшает на 100. Конечно же выводит полученное число.

Информатика

Ответы

klepa-79

Phone math

Объяснение:

Вроде он, попробуй скачать

arturnanda803
Program colors;
Uses crt;

var color: integer;
label l1;

Begin clrscr;
      l1: write('Введите номер цвета color = ');
          readln(color);

          case color of 0: writeln('Черный');
                        1: writeln('Синий');
                        2: writeln('Зеленый');
                        3: writeln('Голубой');
                        4: writeln('Красный');
                        5: writeln('Фиолетовый');
                        6: writeln('Коричневый');
                        7: writeln('Светло-серый');
                        8: writeln('Темно-серый');
                        9: writeln('Ярко-синий');
                        10: writeln('Ярко-зеленый');
                        11: writeln('Ярко-голубой');
                        12: writeln('Розовый');
                        13: writeln('Малиноый');
                        14: writeln('Желтый');
                        15: writeln('Белый');

          else
          begin
               writeln('Непривильный номер цвета');
               writeln;
               goto l1;
          end;
          end;
      readln;
End.             
de1979nis

1

x = int(input())

if(x >= 100 and x <= 999):

   print("Число трехзначное")

else: print("Число НЕ трехзначное")

2

month = int(input())

if(month >= 1 and month <= 12):

   if(month == 1 or month == 3 or month == 5 or month == 7 or month == 8

      or month == 10 or month == 12):

       print(31)

   elif(month == 2):

       print(28)

   else: print(30)

else: print("Неверно введеный номер месяца!")

3

from sys import exit

month = int(input("Месяц: "))

day = int(input("День: "))

remainder = 0

if(month >= 1 and month <= 12):

   if(month == 1 or month == 3 or month == 5 or

      month == 7 or month == 8 or month == 10 or month == 12):

       if(day >= 1 and day <= 31):

           pass

       else: print("Неверно введены дни месяца!"); exit();

   elif(month == 2):

       if(day >= 1 and day <= 28):

           pass

       else: print("Неверно введены дни месяца!"); exit();

   else:

       if(day >= 1 and day <= 30):

           pass

       else:

           print("Неверно введены дни месяца!"); exit();

       

   for i in range(1, month+1):

       if(i == 1 or i == 3 or i == 5 or i == 7 or i == 8

          or i == 10 or i == 12):

           remainder += 31

       elif(i == 2):

           remainder += 28

       else: remainder += 30

   remainder += day

   print("До нового года осталось: " + str(365 - remainder))

else: print("Неверно введеный номер месяца!")

4

month = int(input())

if(month >= 1 and month <= 12):

   if(month == 12 or month == 1 or month == 2):

       print("Winter!")

   elif(month == 3 or month == 4 or month == 5):

       print("Spring!")

   elif(month == 6 or month == 7 or month == 8):

       print("Summer!")

   elif(month == 9 or month == 10 or month == 11):

       print("Autumn!")

else: print("Wrong number of month!")

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая требует ввести целое число. Проверяет, положительное оно или нет. Если число положительное, - увеличивает его на 200, если нет, -уменьшает на 100. Конечно же выводит полученное число.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

orb-barmanager
Середа-Сергеенков980
mileva84
Лилия-Карпухина337
snezhanaklimenkova
Остап-Лаврова1410
zuzazuza61
luksorsps20096124
stperelyot7833
cheberyako2013
ЮрьевичКарпова1564
Алексеевна
pokupatel688
Мануэлла
▲