const
n=5;
type
t_spisok=record
surname:string[20];
name:string[20];
YearBorn:string[4];
ves:integer;
Rost:integer;
end;
mas=array [1..n] of t_spisok;
var
spis1:mas;
f: file of t_spisok;
i:integer;
Объяснение:
program spisok1;
const
n=5;
type
t_spisok=record
surname:string[20];
name:string[20];
YearBorn:string[4];
ves:integer;
Rost:integer;
end;
mas=array [1..n] of t_spisok;
var
spis1:mas;
f: file of t_spisok;
i:integer;
// То что ниже - это для проверки
begin
Assign(f,'klass9.dat');
Rewrite(f);
for i:=1 to n do begin
with spis1[i] do begin
Write('фамилия: ');
ReadLn(surname);
Write('имя: ');
ReadLn(name);
Write('год рождения: ');
ReadLn(yearborn);
Write('вес(кг): ');
ReadLn(ves);
Write('рост(см): ');
ReadLn(rost);
end;
Write(f, spis1[i]);
end;
Close(f);
Assign(f,'klass9.dat');
Reset(f);
writeln ('фамилия':20,'имя':20, 'год рожд.':10,' вес ':4,' рост ':4);
i:=1;
while not Eof(f) do begin
Read(f, spis1[i]);
with spis1[i] do begin
writeln (surname:20,name:20,YearBorn:10,ves:4,rost:4);
end;
i:=i+1;
end;
close(f);
readln;
end.
Поделитесь своими знаниями, ответьте на вопрос:
С клавиатуры вводится натуральное число. Составить программу проверяющую утверждение верно ли что цифра 7 встречается в числе более двух раз.
Нет, если есть альтернатива
Объяснение:
Т.к. в 4G модемах используются лимитные тарифы на трафик отбрасываем вариант с закачкой больших данных, игра объемом 50 гб влетит в копеечку владельцу модема. С онлайн играми дела тоже плохи, т.к. сеть мобильная могут присутствовать помехи что приведет к временным обрывам соединения, что недопустимо в онлайн играх с высоким темпом (шутеры например). Та же беда с пингом, задержка довольно высокая для комфортной игры из за мобильной сети. Если есть альтернатива через подключение к сети напрямую то лучше использовать ее.