mstapottery
?>

С ЗАДАЧЕЙ Написать программу, которая определяет, является ли целое n, заданное пользователем числом Мерсенна. 4 ≤ n ≤ 2 000 000 000 Число Мерсенна – это натуральное число вида M = 2p – 1, где p – натуральное число число – это натуральное число, которое не делится нацело ни на одно число кроме самого себя и единицы. Важно: Так как n = × , при n= m1 × m2, если m1 > , то m2 < . Также при чётном m1 или m2, n будет чётным. Значит для того, чтобы определить, является ли числом, достаточно проверить его делимость на 2 и на нечётные числа на промежутке от 3 до Примеры: Число 1023 не является числом Мерсенна. Число 127 является числом Мерсенна.

Информатика

Ответы

troyasport
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
farmprofi

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С ЗАДАЧЕЙ Написать программу, которая определяет, является ли целое n, заданное пользователем числом Мерсенна. 4 ≤ n ≤ 2 000 000 000 Число Мерсенна – это натуральное число вида M = 2p – 1, где p – натуральное число число – это натуральное число, которое не делится нацело ни на одно число кроме самого себя и единицы. Важно: Так как n = × , при n= m1 × m2, если m1 > , то m2 < . Также при чётном m1 или m2, n будет чётным. Значит для того, чтобы определить, является ли числом, достаточно проверить его делимость на 2 и на нечётные числа на промежутке от 3 до Примеры: Число 1023 не является числом Мерсенна. Число 127 является числом Мерсенна.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ekater01806
navi35374
Zashchitin Denis
German
kotofei147516
СергейНиколаевич
Татьяна1045
flerbuket332
doorhan42n6868
Конычева-музей&quot;260
ribcage52
rgmarket
sveta1864
polina3mag
iivanovar-da
▲