Поделитесь своими знаниями, ответьте на вопрос:
В файле input.txt записано число N (1<=N<=10000) равное количеству элементов целочисленной последовательности, а затем сами элементы последовательности. Напишите программу, которая вводит данные в массив и находит в данной последовательности номер наибольшего числа, начинающееся и заканчивающееся на разные цифры, а если таких чисел в заданной последовательности нет, то вывести 0. Результаты работы программы записать в файл output.txt
var a, b, c, n, i, j :integer;
s :array [1..10000] of integer;
begin
clrscr;
writeln ('Vvedite razmer masiva');
read (n);
writeln ('Vvedite chislo X');
read (a);
for i:=1 to n do
begin
writeln ('Vvedit s[', i, '] element');
read (s[i]);
end;
for i:=1 to n do
for j:=1 to n-1 do
if s[j]<s[j+1] then
begin
b:=s[j];
s[j]:=s[j+1];
s[j+1]:=b;
end;
for i:=1 to n do
begin
write (s[i], ' ');
if s[i]=a then inc (c);
end;
writeln;
if c>0 then writeln ('3adanoe chislo prisytstvyet') else writeln('3adanoe chislo otsytstvyet');
end.
P.S. Надеюсь на благодарность и лучший ответ.