kampina1
?>

Составить программу. Вывести на печать числа от 5 до 12 и их кубы ( в два столбца) с пояснениями

Информатика

Ответы

s-shulga

print('Числа от 5 до 12:')

for i in range(5, 13):

 print(i)

print('Квадраты чисел от 5 до 12:')

for i in range(5, 13):

 print(i * i)

Объяснение:

Язык - Python 3

maestro6838
Var a,b,c,angA,angB,angC,cs: real;
    s: string;
begin
  write('длины сторон через пробел:  ');
  readln(a,b,c);
  if (a+b>c) and(a+c>b) and (c+b>a) then
  begin
    cs:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b);
    angC:=360*ArcCos(cs)/(2*pi);
    writeln('угол С = ',angC:4:2);
    cs:=(sqr(a)+sqr(c)-sqr(b))/(2*a*c);
    angB:=360*ArcCos(cs)/(2*pi);
    writeln('угол B = ',angB:4:2);
    angA:=180-angB-angC;
    writeln('угол A = ',angA:4:2);
    if (angA<90) and (angB<90) and (angC<90) then
       s:='треугольник остроугольный';
    if (angA>90) or (angB>90) or (angC>90) then
       s:='треугольник тупоугольный';
    if (sqr(a)+sqr(b)=sqr(c)) or (sqr(a)+sqr(c)=sqr(b)) or 
      (sqr(b)+sqr(c)=sqr(a)) then
       s:='треугольник прямоугольный';
       writeln(s);
     end
  else writeln('треугольник составить нельзя');
end.
    
Валерьевич Николаевич1364

var a, b, c: integer;  //инициализация переменных (длин отрезков)

begin  //Начало программы (тело программы)

   write (' Длины сторон: ');  //Вывод сообщения в консоль

   readln (a,b,c);  //Организация ввода (длин отрезков)

   if (a <= b+c) and (b <= a+c) and (c <= a+b) then  //В условии if проверяется, что каждая из сторон меньше либо равна сумме других. Если хотя бы одна будет больше, то все логическое выражение вернет ложь (false). В таком случае сработает ветка else.

       writeln ('Треугольник существует.')

   else

       writeln ('Треугольник не существует.');

readln(); //Инициализация закрытия по нажатию на кнопку

end. //Конец программы

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу. Вывести на печать числа от 5 до 12 и их кубы ( в два столбца) с пояснениями
Ваше имя (никнейм)*
Email*
Комментарий*