Aleksandrivanovna
?>

Zad1 построить текстовое меню (использовать оператор switch) в котором: 1. При выборе опции 1 программа выводит четные числа в диапазоне от 5 до 30 2. При выборе опции 2 программа рисует маршрут из во количество во введите с клавиатуры [6p] Zad2. Загрузить числа i: * Вывести сумму и среднее значение всех загруженных нечетных чисел * Запишите минимальное значение из двузначных чисел. Программа завершает работу, если вы указываете 0 или суммируете 10 чисел. Используйте любой цикл. [8p] Zad3. Напишите программу, в которой вы объявите массив из 10 элементов типа integer, а затем заполните его числами, указанными с клавиатуры, но в массив должны быть введены только счетчики, делимые на 3. Если число, которое вы загрузили с клавиатуры, например, 5 – то это число не должно быть введено в доску. Подсчитайте минимальные, максимальные и средние числа, которые будут загружены в массив. [6p] Zad4. Напишите программу, определите в ней функции и вызовите их: A. функция, которая получает в качестве аргументов целые числа n и m и возвращает результат степени nm. B. функция, которая увеличивает значение переменной на два (функция не возвращает значение Вызов функции для значения, загруженного с клавиатуры. [8p] Хоть какие-то задания, буду очень благодарен. (Могут быть неточности в переводе)

Информатика

Ответы

Aleksei
Решать подобные задачи использование диаграмм.
Очертим три окружности, означающие драмкружок, спортсменов и хор. Области пересечений окружностей означают одновременную принадлежность к двум или трем категориям занятий. Начнем заполнение.
1. Всем трем областям соответствует условие "3 спортсмена посещают и драмкружок, и хор)". Ставим число 3 (помечено красным).
2. В драмкружке 10 ребят из хора. Следовательно, в области пересечения "Драмкружок+хор" должно находиться число 10. Но часть этой области пересекается с областью, где находятся все три категории занятий, поэтому из 10 вычитаем стоящую в этой области красную тройку и получаем число 7 (помечено синим). Т.е. посещают драмкружок и хор, но не занимаются спортом 7 человек.
3. В хоре 6 спортсменов. Рассуждая аналогично (2) получаем синее число 3.
4. В драмкружке 8 спортсменов. Получаем синее число 5.
5. 27 ребят занимаются в драмкружке. Вычитаем из этого количества число ребят, принадлежащее общим областям 7+5+3=15 и получаем 27-15=12 человек, которые занимаются только в драмкружке.
6. Аналогично получаем 11 спортсменов и 19 участников хора.
7. Всего 70 учеников. Вычитая количество учеников, которые чем-либо заняты, определяем, что 10 человек не заняты ничем.
8. Только спортом, как видно из рисунка, занимаются 11 человек

Втрех седьмых классах 70 .из них 27 занимаются в драмкружке,32 поют в хоре,22 увлекаются спортом.в д
zaha98
Var s:string;   
i,sum:integer; // Объявление переменных
begin             // Начинаем программу
writeln('Vvedite chislo'); // Вывод текста
readln(s); // Ввод текста
sum:=0; // Присваиваем переменной sum значение 0 чтобы при вводе текста отличного от 0, программа выводила правильный результат то есть 0.
for i:=1 to length(s) do if s[i]='0' then sum:=sum+1; // Запускаем счетчик с 1 до length(s) что значит эта команда, она считает сколько в тексте символов. И проверяем с 1 символа до length(s) совпадает ли символ со значением 0, если совпадает то прибавляем 1.
writeln(sum); // Вывод суммы
end. // Конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Zad1 построить текстовое меню (использовать оператор switch) в котором: 1. При выборе опции 1 программа выводит четные числа в диапазоне от 5 до 30 2. При выборе опции 2 программа рисует маршрут из во количество во введите с клавиатуры [6p] Zad2. Загрузить числа i: * Вывести сумму и среднее значение всех загруженных нечетных чисел * Запишите минимальное значение из двузначных чисел. Программа завершает работу, если вы указываете 0 или суммируете 10 чисел. Используйте любой цикл. [8p] Zad3. Напишите программу, в которой вы объявите массив из 10 элементов типа integer, а затем заполните его числами, указанными с клавиатуры, но в массив должны быть введены только счетчики, делимые на 3. Если число, которое вы загрузили с клавиатуры, например, 5 – то это число не должно быть введено в доску. Подсчитайте минимальные, максимальные и средние числа, которые будут загружены в массив. [6p] Zad4. Напишите программу, определите в ней функции и вызовите их: A. функция, которая получает в качестве аргументов целые числа n и m и возвращает результат степени nm. B. функция, которая увеличивает значение переменной на два (функция не возвращает значение Вызов функции для значения, загруженного с клавиатуры. [8p] Хоть какие-то задания, буду очень благодарен. (Могут быть неточности в переводе)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bulenbeiser
Pautova1119
Дружинин
olegmgu1
vusokaya13
alenkadon6
oserdyuk41
director3
serg1976g
Mexx9050
prohorovalena
Petrovich
pri02
Batishcheva
Zhilinoe134