evrotrastop64
?>

Даны три вектора, образующие треугольник a=(a1a2a3) , b=(b1b2b3) , c=(c1c2c3) . Написать программу, вычисляющую площадь проекции этого треугольника на плоскость Ax+By+Cz+D=0 .

Информатика

Ответы

sashulyah3183
1.
var x, i: integer;
var c : array[1..31] of boolean;
begin
c := 0;
for i:= 1 to 31 do c[i] := false;
for i := 1 to 31 do begin
readln(x); if (x = 0) then c[i] := true;
end;
writeln('В следующие дни не было осадков: ');
for i:= 1 to 31 do if (c[i]) then writeln(c[i]);
readln(i);
end.

2.
var x,i,n,c: integer;
begin
realn(n);
for i:= 1 to n do
begin
readln(x); if (x < 0) then c := c + x;
end;
writeln('ответ: '); write(c);
readln(x);
end.

P.S. На паскале не писал давно. Код не компилировал (ибо его сюда копипастить без последствий нельзя.), так что могут быть незначительные ошибки. + сразу говорю (как программист с некоторым опытом и будучи уже не школьником) - код го*но. Так никто не делает, так никто не пишет, но для "школьного паскаля" достаточно
peshnoshamon

#include<iostream>

using namespace std;

int main()

{

int n = 0, m = 0, i = 0, g = 0;

cout << "n =";

cin >> n;

cout << "m =";

cin >> m;

const int q = n,w = m;

double a[q][w];

for(i = 0; i<n; i++){

for(g = 0; g<m; g++){

cout << (i + 1) << ' ' << (g + 1);

cin >> a[i][ g ];

}

}

for(i = 0; i < n; i++){

for(g = 0; g < m; g++){

cout << a[ i ][ g ] << "\t";

}

cout << '\n';

}

return 0;

}

у меня ошибки не выдаёт

если переменная должна иметь константное зн., то подставь при объявлении const, но у меня выскакивает ошибка, я исправил момент объявления массива "a", возможно тут была ошибка

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны три вектора, образующие треугольник a=(a1a2a3) , b=(b1b2b3) , c=(c1c2c3) . Написать программу, вычисляющую площадь проекции этого треугольника на плоскость Ax+By+Cz+D=0 .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mshelen732
Olesyamilenina8
b3dllam
Наталья286
egamedicalbuh
ukkavtodor6
magazin3000
Федоровна-Васильева
Семеновна-Павел
LIN1022
oshemkov579
MAXIM76748
Цветкова
zrs-546
andrew409