Nertman45
?>

Петя и Ваня играли в игру: каждый случайным образом брал шар с номером из своей емкости (шары с номерами от 10 до 50 Они сделали по N ходов. Составьте программу, которая определить, кто из ребят выиграл, если известно, что выигрывает тот, кто набрал большую сумму номеров шаров.

Информатика

Ответы

tashovairina

ответ на Python:

from random import randint

a,b = [i for i in range(10,51)],[i for i in range(10,51)]

v,p = 0,0

for i in range(int(input())):

   print('Ход номер',i+1)

   q,w = a[randint(1,len(a)-1)],b[randint(1,len(b)-1)]

   v += w

   p += q

   a.remove(q)

   b.remove(w)

   print('Петя вытащил шарик с номером',q,'его счёт равен',p)

   print('Ваня вытащил шарик с номером',w,'его счёт равен',v)

if p>v:

   print('Победил Петя!')

elif p<v:

   print('Победил Ваня!')

else:

   print('Победила дружба!')

Объяснение:

Yezhov_igor42
Var
  s,sd,sm,sy:string;
  d,m,y,err:integer;
begin
  Write('Введите текущую дату в формате дд/мм/ или дд.мм.: ');
  Readln(s);
  if Length(s)<>10 then Writeln('Неверный ввод')
  else begin
    sd:=s[1]+s[2]; Val(sd,d,err);
    sm:=s[4]+s[5]; Val(sm,m,err);
    sy:=Copy(s,7,4); Val(sy,y,err);
    if err>0 then Writeln('Неверный ввод')
    else begin
      if d<28 then d:=d+1
      else begin
        case m of
        1,3,5,7,8,10,12:
          if d<31 then d:=d+1
          else begin d:=1; m:=m+1 end;
        2:
          if (y mod 4)=0 then
            if d=28 then d:=29
            else begin d:=1; m:=3 end
          else begin d:=1; m:=3 end;
        else
          if d<30 then d:=d+1
          else begin d:=1; m:=m+1 end
        end
      end;
      if m>12 then begin m:=1; y:=y+1 end;
      Str(d,sd); if Length(sd)=1 then sd:='0'+sd;
      Str(m,sm); if Length(sm)=1 then sm:='0'+sm;
      Str(y,sy);
      s:=sd+'.'+sm+'.'+sy;
      Writeln('Завтра будет '+s)
    end
  end
end.
sohrokova809
В каталоге уровень "вверх" означает движение к корневому каталогу, "вниз - от корневого. Обозначим движение "вверх" через уровень+1, "вниз" - через уровень-1. Получаем смещение относительно исходного уровня, равное +1-1-1-1=-2.
Если в результате пользователь оказался в каталоге C:\учеба\информатика \ ГИА, то изначально он должен был находиться на два уровня выше, т.е. в каталоге C:\учеба
К сожалению, такого варианта в ответах нет, следовательно, либо неверно условие, либо ошибка в вариантах ответов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Петя и Ваня играли в игру: каждый случайным образом брал шар с номером из своей емкости (шары с номерами от 10 до 50 Они сделали по N ходов. Составьте программу, которая определить, кто из ребят выиграл, если известно, что выигрывает тот, кто набрал большую сумму номеров шаров.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vitalina3012
Джамалутдинова Докучаев
vantoslaltd
iburejko7
dimaaristov
kapitan19
andreevaanastsiyao82
emartynova25
zakup-r51
Zashchitin Denis
admiral-kazan
AntonovaAvi1716
alexeytikhonov
ser7286
ksoboleva