nastikak8
?>

1) Напишите программу, которое получает с клавиатуры пятизначное число и удаляет из негопервую и последнюю цифру, например, из числа12345 должно получится 234.2) Напишите программу, которая получает склавиатуры значение катетов аи b прямоугольноготреугольника и вычисляет значение гипотенузыс, а затем выводит его на экран. (Использоватьформатный вывод. Вывести 2 знака послезапятой​

Информатика

Ответы

keti0290103

В чем сложность? ЯП: C++, переписать на любой другой не составит труда.

2)

#include <iostream>

#include <math.h>

int main() {

double katetA, katetB, gipotenuzaC;

std::cout << "Введите 2 катета треугольника: ";

std::cin >> katetA >> katetB;

gipotenuzaC = sqrt(katetA * katetA + katetB * katetB);

std::cout << gipotenuzaC;

return 0;

}

Объяснение:

dimari81
Const m=200;
var a: array[1..m] of integer;
    i,j,n: integer;
begin
   write('количество элементов массива:  ');
   readln(n);
   randomize;
   write('массив:  ');
   for i:=1 to n do
   begin
     a[i]:=random(40);
     write(a[i],' ');
   end;
   writeln;
   write('отсортированный массив:  ');  
   for i:=1 to n-1 do
   for j:=i+1 to n do
   if a[i]>a[j] then swap(a[i],a[j]);
   for i:=1 to n do write(a[i],' ');
end.   

количество элементов массива:  10
массив:  32 2 10 22 2 13 25 6 15 6 
отсортированный массив:  2 2 6 6 10 13 15 22 25 32 
lawyer-2019
1. Первая цифра отводится на знак (1 - это -, 0 - это +). Остальные 7 - число в двоичной системе счисления. Причём если число отрицательное, то исходное двоичное число инвертируется, и к нему прибавляется 1.
а) 33 | 16 | 8 | 4 | 2 | 1 - в двоичной системе оно выглядит как 100001
      1 |  0  | 0 | 0 | 0 | 1
Так как оно положительное, то в начале ставится 0. Так как чисел всего 6, а не 7, то после первого нуля следует поставить ещё один.
ответ: 0'0100001
б) -63₁₀ = -111111₂ (переводить уже не буду подробно)
Так как число отрицательное, то в начале ставим 1, так как цифр 6, то ставим после 1 0.
1'0111111
Инвертируем:
1'1000000
Прибавляем 1:
1'1000001
ответ: 1'1000001
в) -254₁₀ = -11111110
Так как цифр 8, то последнюю отбрасываем, а далее по алгоритму:
1'1111111 >> 1'0000000 >> 1'0000001
ответ: 1'0000001

2.' ' '                   . . . . .
а) 11110  б)  10101010
   + 1101     -       11011
=101011     =10001111
в)   1101
     *  101
      1101
+1101
=1000001
Всё, как в обычной арифметике.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Напишите программу, которое получает с клавиатуры пятизначное число и удаляет из негопервую и последнюю цифру, например, из числа12345 должно получится 234.2) Напишите программу, которая получает склавиатуры значение катетов аи b прямоугольноготреугольника и вычисляет значение гипотенузыс, а затем выводит его на экран. (Использоватьформатный вывод. Вывести 2 знака послезапятой​
Ваше имя (никнейм)*
Email*
Комментарий*