Obukhov-Buriko
?>

На языке ПАСКАЛЬ Дано число n. С начала суток минут. Определите, сколько часов и минут будут показывать электронные часы в этот момент. Программа должна вывести два числа: количество часов (от 0 до 23) и количество минут (от 0 до 59 Учтите, что число n может быть больше, чем количество минут в сутках. Входные данные Вводится целое число n. Выходные данные Выведите ответ на задачу. Примеры входные данные 150 выходные данные 2 30 входные данные 1441 выходные данные 0 1

Информатика

Ответы

ИванМолчанов
Жили собі два півники.один працьовитий,а другий ледар.колись завелась там лесичка. є перший,а другому всеодно.нічого мені вона не зробить.потім настала ніч.всі позасинали.а крадійка ока не зімкнула,крадеться непомітно до ледаря.цап! біжить перекидається.другий півник за нею.втекла,нічого за мною повернеться.він змайстрував пастку.чує крадеться,в раз і вона у клітці.питає: -де півник? за подвір*ям відпусти мене,а я заберуся звідсіля.побіг півник визволив ледаря й мовив: -ось бачиш ти на печі грівся із бідою стрівся.зрозумів все ледарь і став працьовитим.
галина

В n будем хранить количество чисел, которые ещё нужно вывести. a и b - предыдущее и текущее числа Фибоначчи. По определению, следующее число Фибоначчи равно сумме двух предыдущих, так что новое значение b будет a + b. Чтобы не заводить новую временную переменную, новое значение a можно будет найти, вычитая из нового b старое a, получится (a + b) - a = b.

Код процедуры:

procedure print_fib(n: integer);

var a, b, t: integer;

begin

   a := 0;

   b := 1;

   while n > 0 do

   begin

       write(b, ' ');

       b := a + b;

       a := b - a;

       n := n - 1;

   end;

end;

Пример основной программы:

begin

   print_fib(10)

end.

Вывод:

1 1 2 3 5 8 13 21 34 55

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На языке ПАСКАЛЬ Дано число n. С начала суток минут. Определите, сколько часов и минут будут показывать электронные часы в этот момент. Программа должна вывести два числа: количество часов (от 0 до 23) и количество минут (от 0 до 59 Учтите, что число n может быть больше, чем количество минут в сутках. Входные данные Вводится целое число n. Выходные данные Выведите ответ на задачу. Примеры входные данные 150 выходные данные 2 30 входные данные 1441 выходные данные 0 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

emilmishin1032
Boykoyelena
msangelika1010
Григорьевич915
ekaterinasamoylova4705
Yekaterina
vedaikin
Бурмистрова-Ирина660
zmlavra
olartamonov6
jeep75
Feyruz90
dmitriyb1
Aliferenko
Pautova1119