КараханянКусков
?>

нужны ответы на тест1. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 4 команд, которая преобразует число 6 в число 29.ответ: 2. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 5 команд, которая преобразует число 2 в число 26.ответ: 3. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 5 команд, которая преобразует число 6 в число 51. ответ: 4. У исполнителя Калькулятор две команды: 1. прибавь 2 2. умножь на 3Напишите программу из 5 команд, которая преобразует число 5 в число 83.ответ: 5. У исполнителя Калькулятор две команды: 1. вычти 2 2. умножь на 3Напишите программу из 5 команд, которая преобразует число 8 в число 50.ответ: 6. У исполнителя Калькулятор две команды: 1. вычти 3 2. умножь на 2Напишите программу из 4 команд, которая преобразует число 8 в число 40.ответ: 7. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 4 команд, которая преобразует число 4 в число 36.ответ: ​

Информатика

Ответы

vkorz594
Мой совет - запомнить как основную формулу для суммы первых n натуральных чисел

S_n=1+2+3+\ldots + n=\frac{n(n+1)}{2}

Доказывается она так: записываем те же числа в обратном порядке:

S_n=n+(n-1)+(n-2)+\ldots +2+1



и складываем эти равенства таким образом: первое слагаемое с первым, второе со вторым и т.д. Поскольку в первой сумме каждое следующее слагаемое на 1 больше предыдущего, а во второй на 1 меньше предыдущего, мы получим сумму одинаковых чисел:

2S_n=(1+n)+(2+n-1)+(3+n-2)+\ldots +(n-1+2)+(n+1);

2S_n=(n+1)+(n+1)+(n+1)+\ldots + (n+1);

слагаемых всего n, поэтому

2S_n=n(n+1)\Rightarrow S_n=\frac{n(n+1)}{2}.



Теперь несложно найти сумму первых n четных чисел. Можно провести подобную выкладку, а можно свести новую задачу к предыдущей:

2+4+6+\ldots +2n=2(1+2+3+\ldots n)=2\frac{n(n+1)}{2}=n(n+1)

ответ: n(n+1)
Бурмистрова-Ирина660
// PascalABC.NET 3.2, сборка 1389 от 01.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var xa,ya,xb,yb,xc,yc:real;
  Write('Введите координаты точки А: '); Read(xa,ya);
  Write('Введите координаты точки B: '); Read(xb,yb);
  Write('Введите координаты точки C: '); Read(xc,yc);
  var xd:=(xb+xc)/2;
  var yd:=(yb+yc)/2;
  var ma:=sqrt(sqr(xd-xa)+sqr(yd-ya));
  Writeln('ma=',ma:0:5);
  var AB:=sqrt(sqr(xb-xa)+sqr(yb-ya));
  var AC:=sqrt(sqr(xc-xa)+sqr(yc-ya));
  var BC:=sqrt(sqr(xc-xb)+sqr(yc-yb));
  var Wb:=sqrt(AB*BC*(sqr(AB+BC)-AC*AC))/(AB+BC);
  Writeln('Wb=',Wb:0:5)
end.

Результат
Введите координаты точки А: 0 0
Введите координаты точки B: 2 1
Введите координаты точки C: -2 3
ma=2.00000
Wb=2.66667

Pascal. записать листинг программы на языке паскаль: треугольник задан координатами вершин а(0; 0),

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужны ответы на тест1. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 4 команд, которая преобразует число 6 в число 29.ответ: 2. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 5 команд, которая преобразует число 2 в число 26.ответ: 3. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 5 команд, которая преобразует число 6 в число 51. ответ: 4. У исполнителя Калькулятор две команды: 1. прибавь 2 2. умножь на 3Напишите программу из 5 команд, которая преобразует число 5 в число 83.ответ: 5. У исполнителя Калькулятор две команды: 1. вычти 2 2. умножь на 3Напишите программу из 5 команд, которая преобразует число 8 в число 50.ответ: 6. У исполнителя Калькулятор две команды: 1. вычти 3 2. умножь на 2Напишите программу из 4 команд, которая преобразует число 8 в число 40.ответ: 7. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2Напишите программу из 4 команд, которая преобразует число 4 в число 36.ответ: ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

TSKaraulova
tarrin-ka
qwert28027170
Olifirenko119
Igorevich_Aleksandrovna1599
lavorenn
Лихачев Полина1978
okison2847
nsh25044
mmctriitsk
gub191025
elenaperemena8
yorestov
khar4550
zipylin