serge-lysoff
?>

PYTHON Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. По введенным координатам двух полей (kl) и (mn) выясните, угрожает ли ферзь, находящийся на поле (kl) , полю (mn) ? Входные данные На вход программе подаются четыре целых числа klmn . Выходные данные Выведите YES или NO в зависимости от ответа на во задачи.

Информатика

Ответы

Viktor1316
Дано: V = 512 Кбайт Р = 640 ×480 пикс N1=16 цв N2 =256 цв Найти: S1 -? S2 - ? Решение: 1) Найдем количество пикселей в изображении: P = 640 ×480 = 307200 пикселей в изображении видеопамяти 2) Найдем глубину кодирования 1 пикселя N = 2^i, где i - глубина кодирования 1 пикселя (количество ячеек памяти, предназначенных для 1 точки экрана) 16 = 2^4 i1 = 4 бит - глубина кодирования 1 пикселя при использоывании 16 цветов 256 = 2^8 i2 = 8 бит - глубина кодирования 1 пикселя при использоывании 256 цветов 3) Найдем объемы памяти нужные для хранения 1 страницы изображения: V1 = i1 × P = 4 × 307200 = 1228800 бит = 153600 байт = 150 Кбайт - займет одна страница изображения при палитре в 16 цветов V2 = i2 × P = 8 × 307200 = 2457600 бит = 300 Кбайт - займет одна страница изображения при палитре в 256 цветов 4) Посчитаем, сколько поместиться страниц экрана при разных палитрах: 512/150 = 3, 4 страницы, если палитра 16 цветов 512/300 = 1,7 страницы, если палитра 258 цветов ответ:3,4 стр при палитре в 16 цветов 1,7 страницы при палитре в 256 цветов.
mzia-mzia-60682
Const
  n = 8;

var
  a,b: array[1..n] of integer;
  i, k, s: integer;

begin
  Randomize;
  Write('Массив 1:  ');
  for i := 1 to n do
  begin
    a[i] := Random(50)+1;
    Write(a[i]:5);
  end;
  Writeln;
  Write('Массив 2:  ');
  for i := 1 to n do
  begin
    b[i] := Random(50)+1;
    Write(b[i]:5);
  end;
  Writeln;
  Write('Результат: ');
  for i := 1 to n do Write(a[i]*b[n-i+1]:5);
  Writeln
end.

Тестовое решение:
Массив 1:     39   10   14   23   37   38   33   48
Массив 2:     22   45    1   17   16   42   21   39
Результат:  1521  210  588  368  629   38 1485 1056

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PYTHON Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. По введенным координатам двух полей (kl) и (mn) выясните, угрожает ли ферзь, находящийся на поле (kl) , полю (mn) ? Входные данные На вход программе подаются четыре целых числа klmn . Выходные данные Выведите YES или NO в зависимости от ответа на во задачи.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

озерская_Мария1234
alisabutusova
sashab82
studiojanara
Yurevich
tanyamurashova11352
format-l3364
ЕленаАлександровна381
Воздвиженская
filippovev1
sky-elena712558
argent
карпова581
vs617
aidapiltoyan43