Грачева мураховская
?>

Составьте программу, которая напечатает все целые трёхзначные числа, которые увеличатся на 20% от своего значения, если их цифры записать в обратном порядке. Например, таким числом является 495​

Информатика

Ответы

amxvel7596
Const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
flag,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          flag:=1;
if flag=1 then
   writeln('Yes')
else
   writeln('N');
end.

вариант 2
const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
k,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          k:=k+1;
if k<>0 then
   writeln('Yes')
else
   writeln('N');
end.
nanasergevn

Объяснение:

Хотя слово «центнер» немецкого происхождения и означает «сто мер», традиционно в Германии в старину за меру веса принимали не килограмм, а фунт, который соответствует приблизительно 500 граммам. То есть 100 фунтов — 50 килограммов. Этой мерой веса в старину пользовались люди, занятые в сельском хозяйстве: например, центнер картофеля — полный мешок, 50 кг. В разных частях Германии центнер был разный: в Баварии, например, — 56 кг; в Брауншвейге — 46,77 кг; в Саксонии — 51,4 кг. Сейчас в Германии берётся усреднённая величина 50 кг[1].

:)

всего доброго

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая напечатает все целые трёхзначные числа, которые увеличатся на 20% от своего значения, если их цифры записать в обратном порядке. Например, таким числом является 495​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bella
kronid12
Вадим
airon-082054
Картузов-Алексей1252
Urmanov19903131
stailwomen31
Светлана константин
Д.О. Игорь
НиколаевнаФ
Усошина1059
aaltuxova16
Kisuha8465
nkochladze
st7307