natura-domA90
?>

Нарисовать в паскале елочку (ствол- прямоугольник, три уровня- треугольники и гирлянда (её сделать при дуг))

Информатика

Ответы

abuley

Работа с двухмерном массивом

Объяснение:

Двухмерные массивы можно представить в виде матрицы где главная ось начинается с левого верхнего угла заканчивая нижним правым углом.

{ 1  2  3  4 }

{ 1  2  3  4 }

{ 1  2  3  4 }

{ 1  2  3  4 }

так выглядит двухмерный массив,если пройтись по диагонали нам нужно вывести числа 1 2 3 4

Написал программу которая выводит главная диагональ на языке С#

учитывать что в данном языке программирования индексы массива идут с нулевого элемента,в коде я заполнил наш массив размером 4 на 4 (16 ячеек) значениями 1 2 3 4 каждый столбец и строчку,потом вывел их на экран.


Вопрос звучит так: Заполнить массив С(4,4). Вывести на экран элементы главной диагонали. Но мне бы
Вопрос звучит так: Заполнить массив С(4,4). Вывести на экран элементы главной диагонали. Но мне бы
Oksana373
В принципе, можно расписать, что делает эта программа (см. вложение). Так как изначально a[6] = 0, то a[3] = 50 раз к a[5] прибавится 2 * a[4] = 38, получится 38 * 50 + a[5] = 1917, затем значение a[5] будет выведено на экран.

Но проще не мучиться и просто написать программу, выполняющую этот код.

python 3.
array = [10, 330, 50, 19, 17, 0, 184, 0]
array_position = 2
program = "[->[->+>+<<]>>[-<+<+>>]<<<]>>."

stack = []
transitions = [None] * len(program)
for k, op in enumerate(program):
    if op == '[':
        stack.append(k)
    elif op == ']':
        v = stack.pop()
        transitions[k] = v + 1
        transitions[v] = k + 1
 
k = 0
while k < len(program):
    op = program[k]
    if op == '.':
        print(array[array_position])
    elif op == '>':
        array_position += 1
    elif op == '<':
        array_position -= 1
    elif op == '[' and array[array_position] == 0:
        k = transitions[k]
        continue
    elif op == ']' and array[array_position] != 0:
        k = transitions[k]
        continue
    elif op == '+':
        array[array_position] += 1
    elif op == '-':
        array[array_position] -= 1
    k += 1
Петя и вася придумали язык программирования мозг. в нём используются 8 ячеек памяти, и есть следую

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нарисовать в паскале елочку (ствол- прямоугольник, три уровня- треугольники и гирлянда (её сделать при дуг))
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Лусине_Ильенков134
Сколько в 2.77 гигабайтов килобайтов
potap-ver20065158
klodialeit36
polina3mag
yuliyaminullina
bd201188
mgrunova
aistenok-28
alex-kuzora4411
Yekaterina_Popova1413
Elenazhukovafashion7
vkorz594
Zibuxin3
homeo85
sales5947