randat887040
?>

класс. Python. Дан массив, содержащий 8 положительных целых чисел, не превышающих 1000 Необходимо найти в этом массиве количество двузначных элементов, которые кратны числу 5, и заменить каждый из таких элементов на это количество. Напишите программу для решения этой задачи. В качестве результата программа должна вывести изменённый массив, по одному элементу в строке. Язык программирования Python.

Информатика

Ответы

zanthia94

n = int(input())

#Сколько чисел

value = []

z = 0

for i in range(n):

   t = int(input())

   value.append(t)

   if t // 100 == 0 and t % 5 == 0:

       z += 1

for i in value:

   if i // 100 == 0 and i % 5 == 0:

       g = value.index(i)

       value.remove(i)

       value.insert(g, z)

for i in value:

   print(i)

diana8
Код#include <iostream>constexpr double bites_to_megabytes(double a) {    return a / 8388608;}constexpr double megabytes_to_gigabytes(double a) {    return a / 1024;}int main() {    long long a;    short type;    bool is_correct = false;    double answer;    do {        std::cin >> a;        std::cout << "[1] Megabytes \n"                  << "[2] Gigabytes \n"                  << "Convert to [1] or [2]: ";        std::cin >> type;        if (type == 1 or type == 2) {            is_correct = true;        } else {            std::cout << "Meh. Try to type again. \n" << std:: endl;        }    } while (!is_correct);    switch (type) {        case 1:            answer = bites_to_megabytes(a);            break;        case 2:            answer = megabytes_to_gigabytes(bites_to_megabytes(a));            break;    }    std::cout << "An answer of conversion is " << answer << std::endl;    return 0;}
APerova3464
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

класс. Python. Дан массив, содержащий 8 положительных целых чисел, не превышающих 1000 Необходимо найти в этом массиве количество двузначных элементов, которые кратны числу 5, и заменить каждый из таких элементов на это количество. Напишите программу для решения этой задачи. В качестве результата программа должна вывести изменённый массив, по одному элементу в строке. Язык программирования Python.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oledrag7
meteor90
Alekseevna1811
zanthia94
KIRILLSHURYGIN98
Анатольевич1707
Zuriko1421
nkaminskaja
yrgenson2011801
Rufilya-Belov
avto3132
antrotip
bryzgalovag
Шиловский126
Мельникова