gernovoy
?>

Составьте программу по которой на экран будет выводится таблица кодировки в диапазоне кодов от 32 до 255.напомним что символы с кодами меньшими 32 являются управляющими не экранам.​

Информатика

Ответы

olarina6510
//Сделал Лугачев Кирилл
//Специально для
//Все данные вводятся с клавиатуры
program Sravnenie;
var   
a, b: integer; // Стороны 1-ого прямоугольника 
d, c: integer;// Стороны 2-ого прямоугольника 
S1, S2: integer; // Площадь 
buf: integer;// Если площадь 1-ого будет меньше 2-ого                
                   //поменяем местами,что бы избавиться от минуса 
razn: integer; // Разница 2-ух площадей

begin   
Write('Введите стороны 1-ого прямоугольника: '); 
Readln(a, b);
   
Write('Введите стороны 2-ого прямоугольника: '); 
Readln(d, c);   
S1 := a * b; //Площадь 1-ого 
S2 := d * c; //Площадь 2-ого   
if S1 < S2 then  
begin   
buf := S1;   
S1 := S2;   
S2 := buf; 
end;   
razn := S1 - S2;    
Writeln('Площадь 1-ого больше площади 2-ого в - ',razn, ' раз');  
end.
Рогова Ольга1156
//Видимо, это одна задача, так как "изменения" во второй не указаны
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=20;

Var
 ar:array[1..n] of integer;
 i:integer;
begin
 randomize;
 writeln('First array:');
  for i:=1 to n do
   begin
    ar[i]:=random(10)-3;
    write(ar[i]:4);
    if ar[i]>0 then ar[i]:=ar[i]*2 else ar[i]:=0;
   end;
 writeln;
 writeln('Final array:');
  for i:=1 to n do
   write(ar[i]:4);
end.

Пример работы программы:
First array:   2  -3   5   6  -3  -3   1  -2  -3   1   3  -3   4  -3   1  -1   6   6   2   3
Final array:   4   0  10  12   0   0   2   0   0   2   6   0   8   0   2   0  12  12   4   6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу по которой на экран будет выводится таблица кодировки в диапазоне кодов от 32 до 255.напомним что символы с кодами меньшими 32 являются управляющими не экранам.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Цветкова
Меладзе_Владимир1695
agent-ulitka5
sklad
галина
abcd138191
Ferrigen
Шмидт Ирина
Shalito
shugayzhanna6
Yuliya1693
Горностаева831
Voronin-Albertovich
ale99791308
спец Михасов